+ Antworten
Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 15 von 37

Thema: Spezifisches TMC Problem, Hardware erkannt, aber kein Sendersuchlauf

  1. Top | #1
    Male
    Premium-Member
    Avatar von papabong
    My Car
    Focus 2
    Radio
    AS-8606
    Dabei seit
    25.01.2011
    Ort
    Austria
    Beiträge
    50
    Bedankt
    14
    Erhielt 3x Danke in 2 Posts

    Standard Spezifisches TMC Problem, Hardware erkannt, aber kein Sendersuchlauf

    Hallo Zusammen,

    ich versuche seit Wochen meinen TMC Receiver für das 8606 zum laufen zu bekommen.

    Die TMC Hardware wird erkannt, (Amaryllo, Port1, 38400 Baud) und funktioniert auch. Habe ich mit dem Mixsertester getestet. Bei Bedarf kann ich das Log hier posten.

    Mein Problem ist, dass aus irgendwelchen unerfindlichen Gründen das Tuning des TMC Receivers nicht funktioniert und er immer statisch bei 127,1 Mhz steht. Das ist natürlich witzlos, da auf der Frequenz gar nichts gesendet wird.

    Diese Einstellung lässt sich weder durch den manuellen Sendersuchlauf, noch durch einen Eintrag in der sys.txt verändern.

    Weis jemand von euch vielleicht einen Rat ?

    mfg

    papa
    Geändert von papabong (16.09.2011 um 12:43 Uhr)

  2. # ADS
    Circuit advertisement
    Dabei seit
    Always
    Ort
    Advertising world
    Beiträge
    Many


     

  3. Top | #2
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    Ist der Amaryllo Chip bei Dir eingebaut oder hast Du einen externen TMC Receiver ?
    Ausserdem: Um welche Navi-SW geht es ? iGO8 oder Primo ?

  4. Top | #3
    Male
    DAB App Modder
    Avatar von zoulou
    My Car
    VW Passat B7/3C Var. 04/2012
    Radio
    Flyaudio G4909R
    OS-Version
    Android 8.1.0
    Dabei seit
    31.08.2010
    Ort
    PAF
    Beiträge
    2.341
    Blog-Einträge
    10
    Bedankt
    369
    Erhielt 1.505x Danke in 563 Posts

    Standard

    Woher weißt Du, dass es ein Amaryllo chip ist? Mit allem was ich über die Amaryllo Dinger weiß, dürfte der MixSerTester gar nicht funktionieren. Das Log würde mich schon interessieren...
    Dieselben Fragen wie strados hätte ich auch.

  5. Top | #4
    Male
    Premium-Member
    Themenersteller
    Avatar von papabong
    My Car
    Focus 2
    Radio
    AS-8606
    Dabei seit
    25.01.2011
    Ort
    Austria
    Beiträge
    50
    Bedankt
    14
    Erhielt 3x Danke in 2 Posts

    Ausrufezeichen

    Ich habe einen internen TMC Empfänger.

    Ich habe es sowohl mit iGO8 (TMC Empfänger wird bei oben genannten Settings erkannt) als auch mit IGO Primo 1.2 probiert.

    Bei iGO8 kann ich beim Manuellen Sendersuchlauf nicht die Frequenz wählen. Der automatische Senderslauf bring auch keine Sender oder TMC Signale -> steht immer statisch auf 127,1 MHZ.

    [Only members can see the link][Only members can see the link][Only members can see the link]

    Bei iGO 1.2 springt der Sendersuchlauf ab und zu auf 0.0 Mhz und dann wieder sofort auf 127,1Mhz.

    [Only members can see the link][Only members can see the link][Only members can see the link]

    Mixsertester erkennt sowohl den GPS Empfänger (COM2) als auch den TMC Empfänger (COM1).

    [Only members can see the link][Only members can see the link][Only members can see the link]

    Anbei das LOG von Mixsertester:

    [Only members can see the link]

    @Zoulou Ich vermute das es ein Amaryllo Chip ist, da er diesen bei der automatischen Hardwareerkennung im iGO8 sagt.

    Ich hoffe das macht die Hilfe bei der Fehlersuche einfacher.

    mfg

    papa

  6. Top | #5
    Male
    DAB App Modder
    Avatar von zoulou
    My Car
    VW Passat B7/3C Var. 04/2012
    Radio
    Flyaudio G4909R
    OS-Version
    Android 8.1.0
    Dabei seit
    31.08.2010
    Ort
    PAF
    Beiträge
    2.341
    Blog-Einträge
    10
    Bedankt
    369
    Erhielt 1.505x Danke in 563 Posts

    Standard

    Oha, der TMC Chip spricht "Open TMC" (und damit könntest Du tatsächlich einen Amaryllo chip haben)

    Diese Zeile "$PLTTQ,12715,255,0,0,1*52" heißt:

    Tuner Frequency: 12715 -> 127,15 MHz
    Signal Quality: 255 -> wohl eher "Fehler"
    TMC statistics: 0 -> Anzahl korrekter TMC Meldungen
    Tuned: 0 -> kein Signal
    FM Band: 1 ==>> AHA, Du hast einen TMC Tuner für JAPAN !!! (0 wäre Europa, 2: USA)

  7. Folgende Benutzer bedankten sich bei zoulou:


  8. Top | #6
    Male
    Premium-Member
    Themenersteller
    Avatar von papabong
    My Car
    Focus 2
    Radio
    AS-8606
    Dabei seit
    25.01.2011
    Ort
    Austria
    Beiträge
    50
    Bedankt
    14
    Erhielt 3x Danke in 2 Posts

    Standard

    Vielen Dank für deine Hilfe !
    kann ich den tuner selber "umschalten" oder muss ich das ding zurückschicken ?

  9. Top | #7
    Male
    DAB App Modder
    Avatar von zoulou
    My Car
    VW Passat B7/3C Var. 04/2012
    Radio
    Flyaudio G4909R
    OS-Version
    Android 8.1.0
    Dabei seit
    31.08.2010
    Ort
    PAF
    Beiträge
    2.341
    Blog-Einträge
    10
    Bedankt
    369
    Erhielt 1.505x Danke in 563 Posts

    Standard

    Ich denke, dass du ihn nicht selbst umschalten kannst. Sowas wird normalerweise in Hardware vorgegeben (dazu zähle ich hier auch das evtl. vorhandene EEPROM des Chips).
    Es gibt zwar einen Befehl zum Umschalten, aber ich vermute, dass das (wenn überhaupt) nur bis zum nächsten Neustart des Systems hält.

    Aber wenn Du experimentier freudig bist, dann kannst Du ja versuchen ob der Open TMC Befehl zum Umschalten etwas bringt...
    Er lautet:
    Code:
    $PLTCM,B,0
    Du fragst Dich jetzt sicher, wo gebe ich den Befehl ein ...
    Tipp: Mortscript

    Falls du den MixSer eh schon auf der SD Karte hast, brauchst du nur noch eine neue mscr Datei anlegen (z.B. "Set_ECE_TMC.mscr") und eine Kopie von "MixSerNaviStarter.exe" als "Set_ECE_TMC.exe" anlegen.

    In die "Set_ECE_TMC.mscr" kommt dann folgendes:
    Code:
    ErrorLevel( "warn" )
    
    SetComInfo( "COM1:", 0, 38400 )
    
    WriteFile( "COM1:", "$PLTCM,B,0^NL^" )
    Dann die "Set_ECE_TMC.exe" ausführen und mit dem MixSerTester schauen, ob sich an den Ausgaben was getan hat...

    Aber wie gesagt, ich habe wenig Hoffnung für Dich...

  10. Top | #8
    Member Avatar von sender
    My Car
    Passat 3BG TDI
    Radio
    Audiocources AS8601 mit TMC
    Dabei seit
    07.04.2011
    Beiträge
    26
    Bedankt
    3
    Erhielt 5x Danke in 4 Posts

    Standard

    hallo zusammen,
    ich denke das ich wohl das gleiche GPS-Modul mit TMC nachgerüstet habe worüber hier diskutiert wird und welches scheinbar von Audiosources seid 3-4 Monaten eingebaut wird. Das GPS-Board nennt sich GB112A und hat den TMC-Chip von Locosys verbaut. Der Chip heisst TMC-1009 und arbeitet mit dem AdvanceTMC Protokoll und ist abwärtskompatibel zu OpenTMC2. Habe die Beschreibung mal angehängt. [Only members can see the link]
    TMC geht bei mir einwandfrei mit Primo1.2 und auch mit IGO834 als Amaryllo. Bei Navigon habe ich bisher allerdings noch keinen Erfolg gehabt. Hoffe das hilft vielleicht weiter.
    papabong:
    Wegen deinem spezifischem TMC Problem würde ich mal das Gehäuse öffnen und nachschauen ob der Antennenstecker am TMC-Modul noch festsitzt. Die Kabel am GPS- und TMC-Modul sind bei meinen neuen Modul nicht mehr gelötet sondern haben einen kleinen wifi-Stecker.
    weiterhin viel Erfolg!

  11. Folgende Benutzer bedankten sich bei sender:


  12. Top | #9
    Male
    Premium-Member
    Themenersteller
    Avatar von papabong
    My Car
    Focus 2
    Radio
    AS-8606
    Dabei seit
    25.01.2011
    Ort
    Austria
    Beiträge
    50
    Bedankt
    14
    Erhielt 3x Danke in 2 Posts

    Standard

    @ zoulou: Vielen Dank für den Input, ich habe das Mortskript gemäß deinen Angabe gebastelt und siehe da ich habe das FM Band auf 0 umstellen können.

    Nun sieht das Log vom Mixserteser so aus:
    $PLTTQ,18980,255,0,0,0*5B

    Wie du richtig geschrieben hast, verliert das Gerät nach dem Neustart die Einstellungen (FM Band wieder auf 1. Das wäre nicht so schlimm, ich würde einfach das Mortskript so modifizieren, das es bei jedem Start die Parameter übergibt und dann erst iGO Primo startet.

    Ich habe dazu noch einige Fragen und hoffe du kannst mir kurz helfen.

    Was bedeutet bei
    WriteFile( "COM1:", "$PLTCM,B,0^NL^" )

    das ^NL^ ? Ist das das Ende der Eingabe ? Oder muss das bei jedem Befehl mit hinein ?

    Ich möchste gerne bei 88Mhz starten also:

    $PLTCM,S2,8800

    und dann nach TMC Signale suchen

    $PLTCM,A2

    Müsste dann die Einträge wie folgt lauten :

    Code:
    ErrorLevel( "warn" )  
    
    SetComInfo( "COM1:", 0, 38400 )  
    
    WriteFile( "COM1:", "$PLTCM,B,0" )
    
    WriteFile( "COM1:", "$PLTCM,S2,8800 " )
    
    WriteFile( "COM1:", "$PLTCM,A2^NL^" )
    Die Parameter habe ich aus [Only members can see the link]

    Ich werd das mal probieren und euch auf dem laufenden halten.

    @sender: ich habe das AS8606 zerlegt und dieAnschlüsse überprüft. Sieht gut aus, daran liegt es also nicht.
    Geändert von papabong (19.09.2011 um 14:36 Uhr)

  13. Top | #10
    Male
    DAB App Modder
    Avatar von zoulou
    My Car
    VW Passat B7/3C Var. 04/2012
    Radio
    Flyaudio G4909R
    OS-Version
    Android 8.1.0
    Dabei seit
    31.08.2010
    Ort
    PAF
    Beiträge
    2.341
    Blog-Einträge
    10
    Bedankt
    369
    Erhielt 1.505x Danke in 563 Posts

    Standard

    Hat dich nicht die Frequenz von 189,80 MHz etwas irritiert ...?
    Damit wirst du in Europa keine Sender empfangen, hier senden die FM Radiosender zwischen 87,5 und 108,0 MHz ...

    Das ^NL^ steht für "New Line" und sendet die beiden Bytes 0D und 0A. Damit wird jeder Befehl abgeschlossen.

    Ich habe nicht viel Hoffnung, dass du den Tuner so in einen Zustand bringst, damit iGo damit funktioniert. Ich denke nicht, dass es für ein paar Cent TMC Tuner gibt, die weltweit funktionieren können... aber Ausprobieren kann nicht schaden :-)

  14. Top | #11
    Male
    Premium-Member
    Themenersteller
    Avatar von papabong
    My Car
    Focus 2
    Radio
    AS-8606
    Dabei seit
    25.01.2011
    Ort
    Austria
    Beiträge
    50
    Bedankt
    14
    Erhielt 3x Danke in 2 Posts

    Standard

    Hallo zusammen, ich wollte nur vermelden, dass ich nach vielen erfolglosen Versuchen es aufgegeben habe, den TMC Chip "umzuprogrammieren". Vielen Dank für eure Hilfe - zumindest hat es meinem Verständniss für diese Technologie ziemlich auf die Sprünge geholfen.

  15. Top | #12
    Premium-Member Avatar von spalhanav
    My Car
    VOLVO, OPEL
    Radio
    10.1" JOYING Android 4.4Quad Core RNS
    OS-Version
    ANDROID
    Dabei seit
    04.11.2012
    Beiträge
    66
    Bedankt
    7
    Erhielt 2x Danke in 2 Posts

    Standard Problem mit TMC-Modul TM07-2 (Amaryllo) mit locosys-chip

    Hi,
    ich greife diesen thread nochmal auf weil ich auch ein Protokoll vom mixsertester habe das ich gerne interpretiert hätte.
    Das Problem ist, dass ich ein China-Radio(Bluepower BLP870) mit externem TMC-Modul habe(siehe Titel), das nach anfänglichem funktionieren seit einigen Tagen die TMC-Sender nicht mehr fixieren kann. Sowohl mit Primo als auch mit IGO8.
    Die Beschreibung hier des Protokolls war schon sehr hilfreich, aber mich würde noch interessieren, ob bei mir die Empfangsstärke(20-40) zu gering ist oder was.
    Und was bedeutet der Rest wie *5C.

    Z.B.:
    $PLTTQ,9400,23,0,1,0*5C

    Bin für jede Info dankbar.
    Gruß
    Angehängte Dateien Angehängte Dateien

  16. Top | #13
    Male
    DAB App Modder
    Avatar von zoulou
    My Car
    VW Passat B7/3C Var. 04/2012
    Radio
    Flyaudio G4909R
    OS-Version
    Android 8.1.0
    Dabei seit
    31.08.2010
    Ort
    PAF
    Beiträge
    2.341
    Blog-Einträge
    10
    Bedankt
    369
    Erhielt 1.505x Danke in 563 Posts

    Standard

    $PLTTQ,9400,23,0,1,0*5C

    PLTTQ = Open TMC 2.0 Meldung über die aktuelle FM Frequenz mit folgenden Infos
    9400 = Frequenz 94,00 Mhz
    23 = Signalqualität: RSSI in dBuV (Wertebereich kenne ich leider nicht, aber für einen Empfang sollte er scheinbar >50 sein)
    0 = Statistik über TMC Meldungen: 0 (nicht vorhanden) bis 100 (optimal)
    1 = Tuner empfängt Signal
    0 = FM Band: 0 = Europe / Australia / Asia ex Japan; 1 = Japan; 2 = USA
    5C = Checksum

    Ich denke, deine Antennensituation ist suboptimal.

  17. Top | #14
    Premium-Member Avatar von spalhanav
    My Car
    VOLVO, OPEL
    Radio
    10.1" JOYING Android 4.4Quad Core RNS
    OS-Version
    ANDROID
    Dabei seit
    04.11.2012
    Beiträge
    66
    Bedankt
    7
    Erhielt 2x Danke in 2 Posts

    Standard

    $PLTTQ,9400,23,0,1,0*5C

    PLTTQ = Open TMC 2.0 Meldung über die aktuelle FM Frequenz mit folgenden Infos
    9400 = Frequenz 94,00 Mhz
    23 = Signalqualität: RSSI in dBuV (Wertebereich kenne ich leider nicht, aber für einen Empfang sollte er scheinbar >50 sein)
    0 = Statistik über TMC Meldungen: 0 (nicht vorhanden) bis 100 (optimal)
    1 = Tuner empfängt Signal
    0 = FM Band: 0 = Europe / Australia / Asia ex Japan; 1 = Japan; 2 = USA
    5C = Checksum

    Ich denke, deine Antennensituation ist suboptimal.
    Hi,
    ja das denke ich auch. Aber warum ging es zu Beginn. Da wird doch wohl kein Verfallsdatum von nur wenigen Tagen drin sein. Evtl. habe ich es auch beim mehrmaligen Ein- und Ausbau beschädigt?
    Ich habe mit den Antennen schon hin-und herexperimentiert, mit Verstärker und ohne Verstärker und mit der original Bordantenne. Alles dasselbe Ergebnis. Der Hersteller will mir jetzt tatsächlich ein Austauschmodul zusenden, allerdings erst in einigen Tagen wenn wieder Nachschub da ist. Bis dahin suche ich schon mal hier im Forum, es waren ja wohl einige die getauscht(Strados) haben.
    Also zum Schluß:
    Du bist der Meinung, mit den obigen Daten kann kein Senderfix zustandekommen.?!
    Gruß

  18. Top | #15
    Male
    DAB App Modder
    Avatar von zoulou
    My Car
    VW Passat B7/3C Var. 04/2012
    Radio
    Flyaudio G4909R
    OS-Version
    Android 8.1.0
    Dabei seit
    31.08.2010
    Ort
    PAF
    Beiträge
    2.341
    Blog-Einträge
    10
    Bedankt
    369
    Erhielt 1.505x Danke in 563 Posts

    Standard


    Der Tuner rast durch die Frequenzen. So wird das nichts mit TMC.

+ Antworten
Seite 1 von 3 123 LetzteLetzte

Ähnliche Themen

  1. TMC Hardware gefunden, aber keine Sender?!
    Von Mart im Forum iGO8 - Primo
    Antworten: 12
    Letzter Beitrag: 03.08.2011, 17:20
  2. USB Anschluss an meinem 7086 wird nicht erkannt
    Von ministempel im Forum EQUIPMENT - ZUBEHOER - EXTERN - Tools
    Antworten: 10
    Letzter Beitrag: 02.08.2011, 20:49
  3. Ipod /iPhone beim neu starten net erkannt
    Von DrPepper im Forum Winca, Maisun & Co.
    Antworten: 5
    Letzter Beitrag: 07.02.2011, 09:58
  4. igo primo- karten werden nicht erkannt
    Von giz02 im Forum iGO8 - Primo
    Antworten: 8
    Letzter Beitrag: 06.12.2010, 18:39
  5. Antworten: 0
    Letzter Beitrag: 31.10.2010, 22:52

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein

sponsored - supported by


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64