+ Antworten
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 21

Thema: Igo Primo - Uhrzeit verstellt sich immer wieder

  1. Top | #1
    Member Avatar von WH999
    My Car
    Honda
    Radio
    Maxyon
    Dabei seit
    01.08.2011
    Beiträge
    20
    Bedankt
    1
    Erhielt 13x Danke in 8 Posts

    Standard Igo Primo - Uhrzeit verstellt sich immer wieder

    Hallo alle zusammen,
    Ich habe leider das Problem, dass sich die Uhrzeit des Navi (Primo 1.2) immer wieder vestellt und dies jedesmal wenn ich das Gerät (Maxyon Discovery) starte und die Navigation startet, ist die Uhrzeit total verstellt.

    Die System-Uhrzeit des Maxyon-Gerätes bleibt allerdings richtig eingestellt.

    Welche Einstellungen müssen gemacht werden ?

    Danke für eure Antworten.
    Geändert von WH999 (27.10.2011 um 19:56 Uhr)

  2. # ADS
    Circuit advertisement
    Dabei seit
    Always
    Beiträge
    Many


     

  3. Top | #2
    Male
    Premium-Member
    Avatar von bloodymarrie
    My Car
    Golf 6
    Radio
    Zenec für Golf 6
    Dabei seit
    07.01.2012
    Beiträge
    54
    Bedankt
    14
    Erhielt 2x Danke in 2 Posts

    Standard

    Ich greife das Thema mal nochmal auf.
    Hat jemand eine Lösung für dieses Problem gefunden?
    Habe dasselbe Problem bei Primo 2.0.
    Aus diesem Grund dauert die Positionsbestimmung auch recht lang.

  4. Top | #3
    Male
    DAB App Modder
    Avatar von zoulou
    My Car
    VW Passat B7/3C Var. 04/2012
    Radio
    Flyaudio G4909R
    OS-Version
    Android 8.1.0
    Dabei seit
    31.08.2010
    Ort
    PAF
    Beiträge
    2.341
    Blog-Einträge
    10
    Bedankt
    369
    Erhielt 1.505x Danke in 563 Posts

    Idee

    Hallo, es gibt ja mittlerweile gefühlt ein duzend Threads zu diesem Thema. Es wird immer schwieriger die Informationen zu bündeln...

    Ich hätte da einen Lösungsansatz, der unabhängig vom eingesetzten Gerät und auch unabhängig von der eingesetzten Navi SW sein könnte. Einzige Vorraussetzung wäre, dass WinCE6 zum Einsatz kommt.
    Und wie? Über mein [Only members can see the link].

    Idee, die ich "demnächst" umsetzen werden:

    a) eine "inj_datetime.dll" wird in den Navi Prozess (navigon.exe, igo.exe, etc.) eingeschleust. Diese zwängt sich zwischen die Navi SW und den Windows Datum/Zeit/Zeitzonen API Funktionen. Damit hat die inj_datetime.dll volle Kontrolle darüber, was die Navi SW bzgl. Zeit so anstellen möchte.

    b) Wenn die Navi SW die Zeit setzen will, aber die Differenz zwischen aktueller Zeit und neuer Zeit zw. 50 Minuten und 25 Stunden liegt, dann wird die inj_datetime.dll dies verhindern.

    Warum diese Zeiten?

    Bei unter 50 Minuten Differenz ist es wohl "nur" eine erwünschte Korrektur der Zeit, weil alle RTC Chips (RTC=Real Time Clock) eine mehr oder weniger große Drift haben.
    Bei mehr als 25 Stunden kann man davon ausgehen, dass das aktuelle Datum total falsch ist, z.B. nach einem Hardreset des Geräts (1.1.2005 oder so). Warum nicht 24 Stunden? Ich weiß nicht genau was an der Datumsgrenze im Pazifik so alles theoretisch möglich wäre. 25 Stunden sollte aber überall auf der Welt funktionieren.

    Ein Problem würde aber u.U. bestehen bleiben:
    Die Navi SW würde zwar nicht mehr die Systemzeit verstellen, aber dennoch könnte die Navi SW selbst eine falsche Zeit anzeigen (z.B. bei der vorraussichtlichen Ankunftszeit). Das Problem kann die obige Lösung wahrscheinlich nicht verhindern.

  5. Folgende Benutzer bedankten sich bei zoulou:


  6. Top | #4
    Male
    Premium-Member
    Avatar von bloodymarrie
    My Car
    Golf 6
    Radio
    Zenec für Golf 6
    Dabei seit
    07.01.2012
    Beiträge
    54
    Bedankt
    14
    Erhielt 2x Danke in 2 Posts

    Standard

    Kann man in die sys nicht eintragen, dass das Primo beim Starten die Uhrzeit vom System übernehmen soll?
    Das wäre doch das einfachste. Meine Uhrzeit im System stimmt immer. Nur die Uhrzeit im Primo Programm nicht. Also soll es beim Starten die Sytemuhrzeit synchronisieren.

  7. Top | #5
    Male
    DAB App Modder
    Avatar von zoulou
    My Car
    VW Passat B7/3C Var. 04/2012
    Radio
    Flyaudio G4909R
    OS-Version
    Android 8.1.0
    Dabei seit
    31.08.2010
    Ort
    PAF
    Beiträge
    2.341
    Blog-Einträge
    10
    Bedankt
    369
    Erhielt 1.505x Danke in 563 Posts

    Standard

    Ich habe meine "Systemzeit Verstellungs Verhinderungs Idee" mal online gestellt.
    [Only members can see the link]

    @bloddymarrie: Dein Problem ist dadurch aber nicht gelöst. Deine Systemzeit bleibt ja korrekt, "nur" die iGo Zeit ist bei dir falsch. Da weiß ich keinen Rat.

  8. Folgende Benutzer bedankten sich bei zoulou:


  9. Top | #6
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    Weis jemand, ob es in Primo einen Parameter gibt, um das Setzen (Verstellen) der WinCE Uhrzeit zu verhindern ?

  10. Top | #7
    Male
    Hat es 13x getan
    Avatar von trockensuppe
    My Car
    VW GolfV Plus, Ford Focus MK2 FL
    Radio
    Delphi VW RCD510 und Erisin ES7089 mit WinCE 6
    Dabei seit
    20.11.2009
    Ort
    互聯網上的任意位置
    Beiträge
    5.008
    Bedankt
    1.265
    Erhielt 2.270x Danke in 658 Posts

    Standard

    [timezone]
    sync_os_timezone=0
    reset_os_timezone=0
    NO Support via PN ! “Die Tastatur liegt einsam dort, wenn Vati in der Motherboard”

  11. Folgende 2 Benutzer bedankten sich bei trockensuppe für den nützlichen Beitrag:


  12. Top | #8
    gerco
    Gast Avatar von gerco

    Standard

    bei primo gibt es solch einen Eintrag nicht

  13. Top | #9
    Premium-Member Avatar von DocDoc
    My Car
    Seat Alhambra Bj. 2012
    Radio
    Erisin 3015
    OS-Version
    ANDROID
    Dabei seit
    22.09.2012
    Beiträge
    66
    Bedankt
    9
    Erhielt 6x Danke in 6 Posts

    Standard

    Hallo,

    habe leider auch das Problem, das Primo die Uhrueit des Systems immer um eine Stunde vorstellt.
    Habe mal versucht, den InjectDrv zu installieren. Allerdings verstellt sich die Zeit noch genau wie zuvor.
    Habe ich das InstallScript evtl. falsch angepasst?


    Gestolpert bin ich über diese Zeile.

    # If (SRCPATH ne DSTPATH)
    Was bedeutet das "ne"?

    Danke für die Hilfe,
    Doc

    PHP-Code:
    ErrorLevel("warn")

    # Path with source files
    SRCPATH "\Storage Card\Inject"

    # Path for persistent storage. This can be a folder in flash memory or a SD Card.
    DSTPATH "\StaticStore"
    # If you want the DLLs to be executed from SRCPATH, uncomment following
    #DSTPATH = SRCPATH

    # copy files from source to destination, if different paths are given
    # If (SRCPATH ne DSTPATH)
        
    Copy(SRCPATH "\InjectDrv.dll"DSTPATH "\InjectDrv.dll"TRUE)
        
    Copy(SRCPATH "\inj_audio.dll"DSTPATH "\inj_audio.dll"TRUE)
        
    Copy(SRCPATH "\inj_datetime.dll"DSTPATH "\inj_datetime.dll"TRUE)
        
    Copy(SRCPATH "\inj_autostart.dll"DSTPATH "\inj_autostart.dll"TRUE)
        
    # EndIf

    ####### Common settings for all inj_xxx.dll

    # tell all the inj_xxx.dll where to find the InjectDrv.dll
    RegWriteString"HKLM""SOFTWARE\Inject""InjectDrvPathFileName"DSTPATH "\InjectDrv.dll" )

    # Debug mode for all inj_xxx.dll
    # 0=Disabled, 1=File, 4=Popup, 5=Popup+File
    # NOTE: Log file is created in folder where the injected process is located
    #       Popup (=MessageBox) disappears automatically after 5 seconds
    DEBUGMODE 0
    RegWriteDWord
    "HKLM""SOFTWARE\Inject""DebugMode"DEBUGMODE )

    ####### Specific settings

    # tell Windows to load following dlls into every(!) process 
    # NOTE: you can choose here which inj_xxx.dll you want to use
    # RegWriteMultiString( "HKLM", "SYSTEM\KERNEL", "InjectDLL", Array(DSTPATH & "\inj_audio.dll") )
     
    RegWriteMultiString"HKLM""SYSTEM\KERNEL""InjectDLL", Array(DSTPATH "\inj_datetime.dll") )
    # RegWriteMultiString( "HKLM", "SYSTEM\KERNEL", "InjectDLL", Array(DSTPATH & "\inj_audio.dll", DSTPATH & "\inj_datetime.dll", DSTPATH & "\inj_autostart.dll") )

    ####### inj_audio.dll specific settings

    # tell the inj_audio.dll to infect only following processes; inj_audio.dll will unload itself from any other process
    # RegWriteMultiString( "HKLM", "SOFTWARE\Inject", "InjectProcessesAudio", Array("navigon.exe", "mobilenavigator.exe") )

    # optional: enable to play a sound each time when new audio output is generated by Navi SW
    # The location of AUDIOBEEPFILE can be anywhere, does not need to be in DSTPATH !
    # AUDIOBEEPFILE = ""
    #AUDIOBEEPFILE = SRCPATH & "\beep-50-50.wav"
    # RegWriteString( "HKLM", "SOFTWARE\Inject", "AudioBeepFile", AUDIOBEEPFILE )

    ####### inj_datetime.dll specific settings

    # tell the inj_datetime.dll to infect only following processes; inj_datetime.dll will unload itself from any other process
    RegWriteMultiString"HKLM""SOFTWARE\Inject""InjectProcessesDateTime", Array("navigon.exe""mobilenavigator.exe","primo.exe") )

    ####### inj_autostart.dll specific settings

    # tell the inj_autostart.dll to infect only following processes; inj_autostart.dll will unload itself from any other process
    # RegWriteMultiString( "HKLM", "SOFTWARE\Inject", "InjectProcessesAutoStart", Array("manager.exe") )

    # tell the inj_autostart.dll to start this executable
    # AUTOSTART_EXE = "\Storage Card\MixSer\MixSerNaviStarter.exe"
    # RegWriteString( "HKLM", "SOFTWARE\Inject", "AutostartExe", AUTOSTART_EXE )

    Message("Inject installed. Please restart the device."

  14. Top | #10
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    bei primo gibt es solch einen Eintrag nicht
    Bei mir hat's geholfen. Also einfügen, wenn noch nicht vorhanden !

    [timezone]
    sync_os_timezone=0
    reset_os_timezone=0

  15. Top | #11
    Premium-Member Avatar von DocDoc
    My Car
    Seat Alhambra Bj. 2012
    Radio
    Erisin 3015
    OS-Version
    ANDROID
    Dabei seit
    22.09.2012
    Beiträge
    66
    Bedankt
    9
    Erhielt 6x Danke in 6 Posts

    Standard

    Hätte ich schon längst versucht, wenn 2 Posts drüber nicht gesagt worden wäre, das es bei der Primo nicht gehen würde

    Werde ich dann morgen mal testen.
    Danke

  16. Top | #12
    Male
    Super-Mod
    Avatar von Icke
    My Car
    Skoda SuperB Combi 2.0 TSI Elegance
    Radio
    Columbus RNS510
    OS-Version
    Josi FW 5238
    Dabei seit
    28.05.2012
    Ort
    Berlin
    Beiträge
    593
    Bedankt
    77
    Erhielt 1.231x Danke in 150 Posts

    Standard

    das sollte helfen

    [regional.timezone]
    sync_os_timezone=1
    automatic_dst_handling_by_os_force_on=1

  17. Folgende Benutzer bedankten sich bei Icke:


  18. Top | #13
    Male
    Member
    Avatar von sannnn
    My Car
    Volvo XC60
    Radio
    China Ding
    Dabei seit
    04.04.2013
    Beiträge
    14
    Bedankt
    1
    Erhielt 0x Danke in 0 Posts

    Standard

    Ich greife das hoch mal hoch.
    Bei mir ist das gleiche Problem, dass Igo die Systemzeit verstellt.
    In meiner System.ini befindet sich folgender Eintag:
    [regional.timezone]
    auto_index="308"
    index="30"
    last_auto_time_sync="2013.04.20.|08:18:37.000"
    tzbias="-60"
    tzdbias="-60"
    tzdst="1"

    Was könnte die Abhilfe schaffen in meinem Fall?

  19. Top | #14
    Male
    Member
    Avatar von sannnn
    My Car
    Volvo XC60
    Radio
    China Ding
    Dabei seit
    04.04.2013
    Beiträge
    14
    Bedankt
    1
    Erhielt 0x Danke in 0 Posts

    Standard

    Ich greife das hoch mal hoch.
    Bei mir ist das gleiche Problem, dass Igo die Systemzeit verstellt.
    In meiner System.ini befindet sich folgender Eintag:
    [regional.timezone]
    auto_index="308"
    index="30"
    last_auto_time_sync="2013.04.20.|08:18:37.000"
    tzbias="-60"
    tzdbias="-60"
    tzdst="1"

    Was könnte die Abhilfe schaffen in meinem Fall?
    Kann das keiner beantworten?
    Ich habe noch festgestellt, dass die Zeile tzdst="1" immer automatisch auf "1" zurückgesetzt wird, egal, wie ich das ändere.

  20. Top | #15
    gerco
    Gast Avatar von gerco

    Standard


    die system.ini ist im save Ordner.
    Hast Du den schon mal komplett gelöscht?

+ Antworten
Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. Uhrzeit anzeigen?
    Von taz87 im Forum HARDWARE-Helpdesk
    Antworten: 11
    Letzter Beitrag: 22.02.2012, 19:01
  2. Mazda TID-7501: Zeit im Navigations Menü setzt sich immer zurück
    Von Bucco im Forum Winca, Maisun & Co.
    Antworten: 0
    Letzter Beitrag: 10.09.2011, 15:41
  3. Primo Läuft kurz und Hängt sich dann auf??
    Von thebesthulck im Forum iGO8 - Primo
    Antworten: 7
    Letzter Beitrag: 07.08.2011, 17:59
  4. VW 7088 Mein bildschrim wird immer wieder mal schwarz was machen ???
    Von Magic.87 im Forum Winca, Maisun & Co.
    Antworten: 4
    Letzter Beitrag: 25.05.2011, 16:50
  5. W7TD - Einstellung (Uhrzeit)
    Von susushi im Forum Winca, Maisun & Co.
    Antworten: 6
    Letzter Beitrag: 27.10.2010, 15:35

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein

sponsored - supported by


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64