+ Antworten
Ergebnis 1 bis 14 von 14

Thema: TMC Einstellungen nach jedem Neustart verschwunden

  1. Top | #1
    Male
    VIP-Member
    Avatar von Mr.X
    My Car
    BMW 3er E46
    Radio
    MAXYON Alabama II GPS
    OS-Version
    Windows CE
    Dabei seit
    03.08.2014
    Ort
    Gelsenkirchen
    Beiträge
    130
    Bedankt
    12
    Erhielt 5x Danke in 5 Posts

    Standard TMC Einstellungen nach jedem Neustart verschwunden

    Hallo,
    ich habe folgendes Problem:
    Wenn ich bei meinem Navi (IGO 8, Naviradio mit S100 Plattform) die passenden TMC Einstellungen vornehme funktioniert alles einwandfrei,jedoch nach dem Abschalten des Gerätes und später wieder einschalten steht wieder alles auf "Auto".
    Wo kann ich die Einstellungen des TMC Empfängers dauerhaft einfügen?
    In der "System ini" steht folgender Eintrag:

    [tmc]
    saved_config_available="1"
    saved_config_classname="NMEA_GPSTMC_AMARYLLO"
    saved_config_portname="COM"
    saved_config_port="5"
    saved_last_tuning_mode="1"
    auto_tuning="1"
    saved_last_frequency="951"

    Im Sys txt. steht nicht vom TMC

    Eingegeben unter TMC Einstellungen habe ich:
    Protokoll: Amaryllo
    Port:5
    Baudrate:19200

    wie gesagt es läuft sonst ohne Probleme,nur sind immer die Einstellungen weg nach dem Neustart.


    Was kann ich tun?

    Gruß an die Helfer
    Mr.X

  2. # ADS
    Circuit advertisement
    Dabei seit
    Always
    Ort
    Advertising world
    Beiträge
    Many


     

  3. Top | #2
    gerco
    Gast Avatar von gerco

    Standard

    Wenn in der sys.txt nichts davon drin steht,
    vermute ich, daß Dein Gerät sich die Einstellungen aus der device.ini holt.

    Hast Du solch einen Eintrag in der sys.txt

    [device]
    type="Delco_QX-BH751T"

    Delco_QX-BH751T ist ein Beispielname für ein Gerät was in der data.zip
    config\Devices abgelegt ist.
    Wenn solch ein Eintrag vorhanden ist, bitte löschen oder ein ; davor setzen wie hier.
    ; type="Delco_QX-BH751T"

    Dann alle Eintragungen für GPS und TMC in sys.txt erstellen

    [gps]
    port=1
    baud=115200
    send_init=0
    set_messages=0
    sent_init_type=0
    background_navigation=1

    [tmc]
    source="virtserial"
    port="COM,3"
    baud=38400
    enable_flow_events=1 ;(0) haven't seen any flowing
    flow_stripe_blinking_time=1000 ;(0) in msecs
    show_all_provider_list=1 ;(0)
    near_provider_distance_km=100 ;(30)
    auto_band_search_up=0 ;(0)
    auto_tuning=1
    ;use_new_standard=1
    ignore_sid=1

    Das sind alles nur Beispiele, die für Dein Gerät angepasst werden müssen.

    Für einen Amaryllo chip solltest Du dieses einsetzen.

    [tmc]
    source="amaryllodyn"
    internal_tmc_name="amaryllodyn"
    port="COM,6"
    baud=38400
    logic_delay=500
    tuner_model= "IGO_GPSTMC_TUNER"
    show_all_provider_list=1
    tmcprovider_ignore_altfreq=1
    ;on station section
    tmcprovider_rssi_stability=0
    tmcprovider_rssi_average=0
    ; search section
    near_provider_distance_km=100
    area_size=500
    show_debug_tmc_win=0
    debug_tmc_win_silent_mode=0
    amaryllodyn_white_filter_state=1
    use_picode_for_country_code=0
    amaryllodyn_search_mode=2
    tmcprovider_allow_stay_on_first_free=0
    tuneralg_rds_repeat_check=0
    tmc_provider_name_use_old=1
    tmc_provider_name=0
    tmcprovider_break_scan_timeout=180
    tmcprovider_tuner_scanlevel=1
    tmcprovider_max_freeze_timeout=60
    tuneralg_rds_packet_timeout=7500
    tuneralg_8a_packet_timeout=10500
    tuneralg_3a_packet_timeout=30000
    tuneralg_last_8a_packet_timeout=60000
    amaryllodyn_use_rds_input=0
    check_ltn_support=1
    tmclogic_hun="0,1,100,0,8500:10500:20000:40000,0,1 00,100,1"
    tmclogic_ger="1"
    tmclogic_aut="1"
    hide_unlicensed_providers=1
    use_picode_for_country_code=0

    Auch hier gilt:
    Port und Baudrate müssen angepasst werden.

    Im Hauptverzeichnis müssen 2 Dateien liegen
    AmarylloTMC.dll und
    AmarylloTMC.lib


    Nicht vergessen!!!!
    Vor dem nächsten Start MUSS unbedingt der Ordner SAVE gelöscht werden.
    Geändert von gerco (14.09.2014 um 19:29 Uhr)

  4. Folgende Benutzer bedankten sich bei gerco:


  5. Top | #3
    Male
    VIP-Member
    Themenersteller
    Avatar von Mr.X
    My Car
    BMW 3er E46
    Radio
    MAXYON Alabama II GPS
    OS-Version
    Windows CE
    Dabei seit
    03.08.2014
    Ort
    Gelsenkirchen
    Beiträge
    130
    Bedankt
    12
    Erhielt 5x Danke in 5 Posts

    Standard

    Hallo,
    kein Device Eintrag im sys txt.,
    alle Devices im Ordner gelöscht,
    alle Daten im sys txt eingegeben,
    habe nur eine "gpstmc.dll" im Hauptverzeichnis,
    Saveordner gelöscht.

    Passiert ist folgendes:Alles Top,GPS und TMC liefen wunderbar,mußte nix einstellen!
    Dann Gerät aus und wieder an: GPS top, TMC wieder auf "Auto".wieder von Hand alles eingegeben,aus/an- Einstellungen wieder weg.
    Warum speicher er GPS aber nicht TMC

    Nachtrag,Habe jetzt dein kompletten Sys txt genommen und angepasst.auch die beiden dll/lib aus dem Download.
    werde später noch mal testen.
    Geändert von Mr.X (14.09.2014 um 12:37 Uhr)

  6. Top | #4
    gerco
    Gast Avatar von gerco

    Standard

    Deine SD Karte ist doch wohl hoffentlich NICHT schreibgeschützt!?

  7. Top | #5
    Male
    VIP-Member
    Themenersteller
    Avatar von Mr.X
    My Car
    BMW 3er E46
    Radio
    MAXYON Alabama II GPS
    OS-Version
    Windows CE
    Dabei seit
    03.08.2014
    Ort
    Gelsenkirchen
    Beiträge
    130
    Bedankt
    12
    Erhielt 5x Danke in 5 Posts

    Standard

    Nein,kein Schreibschutz aktiv.Zumindest weiß ich nicht ob an einer Micro SD Card ein Schreibschutz aktivierbar ist.
    Wie gesagt teste später noch mal.

    --- Update ---

    Leider kein Erfolg.
    TMC Einstellung wird nicht gespeichert.

  8. Top | #6
    gerco
    Gast Avatar von gerco

    Standard

    Die "Auto" Einstellung funktioniert erst ab Primo = IGO9 einwandfrei.
    Com Port und Baudrate also bitte NICHT auf "Auto" stellen.
    Das hat schon öfter zu unbekannten Problemen geführt.
    Diese Eintragungen dürfen in der sys.txt NICHT fehlen.

  9. Top | #7
    Male
    VIP-Member
    Themenersteller
    Avatar von Mr.X
    My Car
    BMW 3er E46
    Radio
    MAXYON Alabama II GPS
    OS-Version
    Windows CE
    Dabei seit
    03.08.2014
    Ort
    Gelsenkirchen
    Beiträge
    130
    Bedankt
    12
    Erhielt 5x Danke in 5 Posts

    Standard

    Hallo Gerco,
    das ist ja genau das Problem!
    Ich hab alles von Hand eingegeben,nach dem Neustart ist wieder alles auf "Auto"
    Eintragung im sys txt hilft auch nicht.

  10. Top | #8
    gerco
    Gast Avatar von gerco

    Standard

    Nach jeder, auch noch so kleinen Änderung, in/an der sys.txt MUSS SAVE gelöscht werden.

  11. Top | #9
    Male
    VIP-Member
    Themenersteller
    Avatar von Mr.X
    My Car
    BMW 3er E46
    Radio
    MAXYON Alabama II GPS
    OS-Version
    Windows CE
    Dabei seit
    03.08.2014
    Ort
    Gelsenkirchen
    Beiträge
    130
    Bedankt
    12
    Erhielt 5x Danke in 5 Posts

    Standard

    Hab ich!-Trotzdem hauts nich hin...

    Ich werde morgenfrüh mal die "igo8_erisin" Version aus dem DL testen(mit meinen Karten).

    Vieleicht steckt der Eintrag in der "start UI"?
    Geändert von Mr.X (14.09.2014 um 20:49 Uhr)

  12. Top | #10
    gerco
    Gast Avatar von gerco

    Standard

    Du scheinst eine exotische Version zu haben.
    Hol Dir lieber die Version hier aus dem Download.
    Die funktioniert auf jeden Fall.
    Deine Karten kannst Du anschließend dann dort reinschieben.
    Ein eventuell vorhandener SAVE Ordner muß natürlich vorher gelöscht werden.
    Geändert von gerco (15.09.2014 um 09:56 Uhr)

  13. Top | #11
    Male
    VIP-Member
    Themenersteller
    Avatar von Mr.X
    My Car
    BMW 3er E46
    Radio
    MAXYON Alabama II GPS
    OS-Version
    Windows CE
    Dabei seit
    03.08.2014
    Ort
    Gelsenkirchen
    Beiträge
    130
    Bedankt
    12
    Erhielt 5x Danke in 5 Posts

    Standard

    Ich habe in meiner IGo Version noch mal rumgesucht,find aber nix was man noch einstellen könnte...
    Was sind das wohl für Einträge in der StartUI,das einzige was mit TMC dort steht:

    btn_CSTMC.y 1600
    .tmc.auto_tuning 1
    .tmc.ignore_all_events 0
    vTmcReplanMode.set L"AUTO"


    tmc_announce_obs.start

    <observer use_tmc_obs model="tmc.ignore_all_events" onchange='ADVNAV_RECALC' start>
    <observer no_route model="navigation.waypoints.list.isempty" onchange='run sc_enable_offroute_recalc' start>
    <observer map_modetobool model="map.map_mode" onchange='run sc_map_mode_to_bool' start
    >

    Irgendwo muß die Einstellung doch stehen,
    ich schau mal was ich im Downloadbereich finde.
    (Ich hatte eine Primo Version drauf (Die für RR Geräte),da habe ich die TMC Einstellungen nicht hinbekommen,diese Version sah auch nicht so toll aus...).

  14. Top | #12
    gerco
    Gast Avatar von gerco

    Standard

    (Ich hatte eine Primo Version drauf (Die für RR Geräte),da habe ich die TMC Einstellungen nicht hinbekommen,
    Wer hat Dir denn den Floh ins Ohr gesetzt?
    Die ist nun wirklich nicht zu empfehlen.
    Hohl Dir aus dem Download die Basic Variante.
    Passe die sys.txt wie oben beschreiben an.
    Für den Anfang nur aber auch nur die GPS und TMC Einträge mehr NICHT.
    Dann die Karten aus Deinem Paket.
    Einen vorhandenen SAVE Ordner LÖSCHEN.

    Erst wenn alles läuft solltest Du Dein IGO mit mehr Funktionen wie TTS Stimmen etc.
    Dann aber nicht vorher die sys.txt l a n g s a m Nachbearbeiten = auffüllen
    Stück für Stück, um Gotteswillen nicht alles auf einmal.
    Das endet sonst wieder mit einem Fiasko.

  15. Top | #13
    Male
    VIP-Member
    Themenersteller
    Avatar von Mr.X
    My Car
    BMW 3er E46
    Radio
    MAXYON Alabama II GPS
    OS-Version
    Windows CE
    Dabei seit
    03.08.2014
    Ort
    Gelsenkirchen
    Beiträge
    130
    Bedankt
    12
    Erhielt 5x Danke in 5 Posts

    Standard

    Hallo,lade gerade Version iGO8-3-5-193799 runter.

    Ja,schimpf du nur,ich wollte halt mal testen...

    Mir ist gerade was aufgefallen:
    Bei meiner Version von IGO läuft TMC immer ,ohne was einzustellen, wenn ich vor dem Ausschalten des Radio vorher Igo beende!!!
    Auch wenn ich das Radio nicht ausschalte,wenn ich igo beende und wieder starte läuft TMC!
    was ist das nur?



    Nachtrag:Ich habe ein Gerätereset durchgeführt,jetzt läuft mein tmc!


    in der sys ini steht nichts von gps oder tmc.Nur in der system ini steht:
    [tmc]
    saved_config_available="1"
    saved_config_classname="NMEA_GPSTMC_AMARYLLO"
    saved_config_portname="COM"
    saved_config_port="5"
    saved_last_tuning_mode="0"
    auto_tuning="0"
    saved_last_frequency="992"

    ich versteh das nicht mehr...
    Geändert von Mr.X (17.09.2014 um 20:37 Uhr)

  16. Top | #14
    Male
    VIP-Member
    Themenersteller
    Avatar von Mr.X
    My Car
    BMW 3er E46
    Radio
    MAXYON Alabama II GPS
    OS-Version
    Windows CE
    Dabei seit
    03.08.2014
    Ort
    Gelsenkirchen
    Beiträge
    130
    Bedankt
    12
    Erhielt 5x Danke in 5 Posts

    Standard


    Seid dem Reset läuft alles bestens!
    TMC startet ohne das etwas eingestellt werden muß!
    Sogar wenn ich das TMC Modul an einem USB Hub zusammen mit einem Stick anschließe.

    Ich danke für eure Unterstützung.

+ Antworten

Ähnliche Themen

  1. [Software] Fehlende Anzeigen nach MN 7.7.5 Neustart
    Von turnback im Forum Navigon
    Antworten: 5
    Letzter Beitrag: 10.07.2014, 15:00
  2. [GELÖST] Aurora 2 Radio geht nach Neustart nicht mehr von selber ins Navi
    Von Dennis-astra im Forum iCarTech
    Antworten: 1
    Letzter Beitrag: 22.02.2014, 20:37
  3. [WinCE] Wince 6 USB TMC Problem / Registry nach neustart wieder auf Standard.
    Von Bladerunner im Forum WinCE Tools
    Antworten: 2
    Letzter Beitrag: 30.01.2014, 01:56
  4. Antworten: 6
    Letzter Beitrag: 28.04.2013, 12:18
  5. Mitsubishi GPS IGO nach jedem neustart suchen hilfe
    Von xxdoublexx im Forum RoadRover
    Antworten: 0
    Letzter Beitrag: 09.06.2012, 11:56

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein

sponsored - supported by


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64