+ Antworten
Seite 5 von 5 ErsteErste ... 345
Ergebnis 61 bis 68 von 68

Thema: S100 Navigon installieren

  1. Top | #61
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider2.0i.e, BMW 330i
    Radio
    Roadrover I7104TR + I7037V2; TMC Pro, DAB+
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.063
    Blog-Einträge
    1
    Bedankt
    266
    Erhielt 2.372x Danke in 1.922 Posts

    Standard

    Die If-then-else Abfrage musst Du so schreiben, dass sie die Installation der Fonts + den Start der Navixxx.exe "überspring", wenn der Prozess bereits läuft, und stattdessen das in Hintergrund laufende Navigations "Fenster" wieder in den Vordergrund holt (show).
    =>> Bitte keine Supportanfragen per PN, dafür ist das Forum da !!!


  2. # ADS
    Circuit advertisement
    Dabei seit
    Always
    Ort
    Advertising world
    Beiträge
    Many


     

  3. Top | #62
    Male
    Member
    Avatar von PeHM
    My Car
    Mondeo
    Radio
    RNS NAVISKAUTO (MS0263)6,2" 6.0 Doppel Din Autoradio DVD Player
    OS-Version
    Windows CE
    Dabei seit
    13.12.2016
    Beiträge
    13
    Bedankt
    1
    Erhielt 2x Danke in 2 Posts

    Standard

    Danke @strados, habe ich probiert. Aber egal wie ich es mache:
    ------------------------------------------------------
    If(FileExists("\Windows\arial.ttf"))
    RUN "\StorageCard\Navigon\Navigon.exe"
    vorangestellt
    --------------------------------------------------------------------
    oder aus dem MortScript
    # Navigation software executable
    NAVI_SW_PATH = "\StorageCard\NAVIGON\navigon.exe"
    NAVI_SW_WINDOW_TITLE = "Mobile Navigator"
    NAVI_SW_PROCESS_NAME = "navigon.exe"

    # If Navi SW already running, then bring Navi SW into foreground and exit this script
    If ( ProcExists( NAVI_SW_PROCESS_NAME ) = TRUE )
    Show( NAVI_SW_WINDOW_TITLE )
    Exit
    EndIf
    vor den Fonts gesetzt
    ------------------------------------------------------
    fürt das nur zu weiteren Problemen mit der Darstellung oder zu Abstürzen. Das ist aber nicht mein eigentliches Problem, mit dem Weg-klicken des StVo-Hinweis könnt ich leben, nur das bei jedem Script was ich starte, auch das originale für die arial-fonts hier aus dem Forum, habe ich den Effekt dass in der Navigation kein Ton mehr vorhanden ist.

    Hierfür fehlt mir jeglicher Hinweis oder Idee?

    Gibt es eine Möglichkeit die arial-fonts fest im Win-CE einzubinden, mit dem Total-Comander oder so. Bisher hab ich mir das System noch nicht angeschaut.
    Anmerkung: Meine Fähigkeiten in Bezug auf Scrpting und Systemen sind nur beschränkt, habe nur Erfahrungen mit DOS und Basic (Steinzeit-PC`s) und Windows-Kentnisse aus den Office Programmen (Scripte für Outlook und Excel)
    Grüße, Pe

  4. Top | #63
    Male
    Super-Mod
    Avatar von krebsi
    My Car
    Passat 3C Variant HL Deep Black
    Radio
    Roadrover 7037 i10 + DAB + DVBT + TMC
    OS-Version
    Windows CE
    Dabei seit
    15.01.2010
    Ort
    München
    Beiträge
    5.248
    Bedankt
    391
    Erhielt 892x Danke in 738 Posts

    Standard

    Die Fonts haben mit Umlaute nichts zutun!

  5. Top | #64
    Male
    Member
    Avatar von PeHM
    My Car
    Mondeo
    Radio
    RNS NAVISKAUTO (MS0263)6,2" 6.0 Doppel Din Autoradio DVD Player
    OS-Version
    Windows CE
    Dabei seit
    13.12.2016
    Beiträge
    13
    Bedankt
    1
    Erhielt 2x Danke in 2 Posts

    Standard

    Die Fonts haben mit Umlaute nichts zutun!
    Danke, aber wie bekomme ich die Umlaute richtig angezeigt? Sie sind ja nicht nur in der StVo Anzeige falsch, auch in den anderen Menus und auch in den selbst geschriebenen Favoriten und Adressen.

    Des weiteren denke ich, das die Navigation vom WinCe mit einem eigenen Script gestartet wird. Unter Einstellungen lege ich die Start-Datei fest. Wechsele ich später die Anzeige, Radio und wieder zurück zur Navigation, so wird zur laufenden Anwendung gewechselt und nicht das Programm neu gestartet. Es ist auch gleich, ob ich mit der Taste, dem Touch oder der LFB wechsele. Deshalb meine ich, dass intern im WinCE eine Anwendung oder ein Script dafür läuft, jedes weitere Script bringt dann nur Fehler, wie den Verlust vom Sound oder Abstürze.

    Also bleibt nur die Frage, wie bekomme ich die richte Anzeige von den Umlauten hin?

  6. Top | #65
    Male
    Super-Mod
    Avatar von krebsi
    My Car
    Passat 3C Variant HL Deep Black
    Radio
    Roadrover 7037 i10 + DAB + DVBT + TMC
    OS-Version
    Windows CE
    Dabei seit
    15.01.2010
    Ort
    München
    Beiträge
    5.248
    Bedankt
    391
    Erhielt 892x Danke in 738 Posts

    Standard

    Über das Problem wurde schon mal diskutiert, kann es aber nicht mehr funden. Was wäre wenn Du statt "Ö" mal bloß "O" wählen würdest?

  7. Top | #66
    Male
    Member
    Avatar von PeHM
    My Car
    Mondeo
    Radio
    RNS NAVISKAUTO (MS0263)6,2" 6.0 Doppel Din Autoradio DVD Player
    OS-Version
    Windows CE
    Dabei seit
    13.12.2016
    Beiträge
    13
    Bedankt
    1
    Erhielt 2x Danke in 2 Posts

    Standard

    Danke für deine Mühe, krebsi .
    Es geht aber nicht um die Eingabe der Zeichen, sondern um die Darstellung. Und es hat auch etwas mit den Fonts zu tun!

    In einem Nachbarforum und auch hier habe ich die Hinweise darauf gefunden:
    "Arial Fonts für WinCE!
    Das Paket beinhaltet folgende Arial-Schriftarten:
    ARIAL.TTF, ARIALBD.TTF, arialbi.ttf, ariali.ttf, arialk.ttf, ARIAL.ttf
    Oftmals fehlen im Windows/Font Verzeichnis die nötigen Schriften, dadurch kommt es zu einer falschen Darstellung in Programmen (z.B. MN6 Ankunftszeit)."

    Ich habe jetzt folgendes gemacht:
    Ein Script das die Fonts installiert über die Eingabezeile der Navigationstaste gestartet und beendet, anschließend den Pfad geändert und die Navigationssoftware gestartet. Nun werden die Umlaute richtig dargestellt und der Sound ist auch vorhanden. Wie vorher schon vermutet, können keine zwei Scripte laufen.

    Jetzt habe ich aber den Effekt, das die Schriften teilweise sehr klein dargestellt werden. Da werd ich einmal mit anderen oder weniger Fonts experimentieren. Außerdem muß ich mir die "mapdrawer.nfs" und eine eventuelle "mapdrawer_high.nfs" einmal anschauen, b.z.w. nach einer Kartenversion mit passenden mapdrawer sehen.

    Wenn ich eine passende Konstellation gefunden habe, schreib ich es noch mal. Ich denke, dass es den einen oder anderen der über ein baugleiches Gerät verfügt hier interressiert.
    Grüße, Pe

    Noch eine Frage: Was bewirkt der Befehl "raw" in einem script?
    (Hier: RAW "\SDMMC\Navigon\navigon.exe")
    Diese Zeile habe ich in meinem Script weg gelassen und Navigon anschließend selbst gestartet.

  8. Top | #67
    Male
    Super-Mod
    Avatar von krebsi
    My Car
    Passat 3C Variant HL Deep Black
    Radio
    Roadrover 7037 i10 + DAB + DVBT + TMC
    OS-Version
    Windows CE
    Dabei seit
    15.01.2010
    Ort
    München
    Beiträge
    5.248
    Bedankt
    391
    Erhielt 892x Danke in 738 Posts

    Standard

    Es geht aber nicht um die Eingabe der Zeichen, sondern um die Darstellung. Und es hat auch etwas mit den Fonts zu tun!
    Wie machen sich denn die Umlauten bemerkbar bei der Kartendarstellung? Die Fonts haben, soweit ich mich erinnern kann, den Fehler bei der Ankunftszeit und der Geschwindigkeitanzeige, behoben.





    Jetzt habe ich aber den Effekt, das die Schriften teilweise sehr klein dargestellt werden. Da werd ich einmal mit anderen oder weniger Fonts experimentieren.
    Hast Du auch die Navigon.exe von Zoulou genommen?
    Geändert von krebsi (09.01.2017 um 15:40 Uhr)

  9. Top | #68
    Male
    Member
    Avatar von PeHM
    My Car
    Mondeo
    Radio
    RNS NAVISKAUTO (MS0263)6,2" 6.0 Doppel Din Autoradio DVD Player
    OS-Version
    Windows CE
    Dabei seit
    13.12.2016
    Beiträge
    13
    Bedankt
    1
    Erhielt 2x Danke in 2 Posts

    Standard


    Die Umlaute fehlen nist nur im StVo-Hinweis, sonder auch un allen Menus, Adressen sowie allen Strassen und Ortsangaben.
    Hast Du auch die Navigon.exe von Zoulou genommen?
    Wie in meinem ersten Post habe ich eine Version von Dir genommen (kopie seiner Card version>7.7.6>build>657>brand>NAVIGON_EU> platform>PR70_UPG) in der die Navigon.exe 3.575 KB aus 29.06.2013 enthalten ist. Ich habe eben die exe-Dateien von Zoulou verglichen. Er hat noch eine weitere für kl. Schriften hochgeladen, diese habe ich noch nicht getestet.
    Meine Lösung, erst die Fonts installieren und dann die Navigon-Software zu starten, ist leider keine entgültige. Wenn die Software richtig beendet wird, nicht nur im Hintergrund läuft, muß ich auch die Fonts wieder installieren.
    Wenn die Navigon-Software läuft, wird wohl noch ein Script laufen, das den Startbefehl ausliest und prüft ob die Software gestartet ist und gegebenenfals nac heiner vorgegeben Zeit die Software beendet. Wenn ich nun der Software noch einen weiteren Script voranstelle, gibt es Probleme mit dem Sound und gegebenenfalls mit der Grafik oder anderen Routinen. Es wird mir wohl nur übrig bleiben, das WinCE einmal näher zu untersuchen, welche Scripte, Config-Dateien oder andere Möblichkeiten ich habe.
    Danke und Grüße, Pe

+ Antworten
Seite 5 von 5 ErsteErste ... 345

Ähnliche Themen

  1. [WinCE] Navigon Installieren CT 7037
    Von Hanspatt im Forum Navigon
    Antworten: 17
    Letzter Beitrag: 13.10.2015, 14:57
  2. [Hilfe] Navigon auf Asure L2W5 installieren
    Von Maddin991 im Forum Navigon
    Antworten: 23
    Letzter Beitrag: 08.06.2015, 19:34
  3. [Android] navigon in alpha s700 installieren
    Von 214hakan im Forum Navigon
    Antworten: 12
    Letzter Beitrag: 19.09.2014, 10:11
  4. [Hilfe] Navigon auf Audiovox vme9725 installieren
    Von apock im Forum Navigon
    Antworten: 10
    Letzter Beitrag: 21.05.2014, 14:06
  5. Navigon auf Clarion NX 501 installieren
    Von bibo09 im Forum Navigon
    Antworten: 0
    Letzter Beitrag: 01.06.2013, 23:50

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein

sponsored - supported by


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64