+ Antworten
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 19

Thema: Navigon 7.7.6 mit MixSer läuft nicht nur 3 punkte zu sehen

  1. Top | #1
    Male
    Premium-Member
    Avatar von olsch
    My Car
    ford
    Radio
    V6026
    Dabei seit
    01.08.2014
    Beiträge
    30
    Bedankt
    2
    Erhielt 0x Danke in 0 Posts

    Standard Navigon 7.7.6 mit MixSer läuft nicht nur 3 punkte zu sehen

    Hallo ich komme einfach nicht weiter
    das Problem ist das Navigon 7.4.3 und 7.7.5 bei mir viel zu träge laufen am besten läuft 7.7.6 was ja eigentlich schon komisch ist, sollte ja eigentlicheher umgekehrt sein.
    bei denn vorherigen versionen läuft TMC ja ohne MixSer klappt auch wunderbar.
    aber bekomme es bei der 7.7.6 einfach nicht hin.
    mein TMC Port ist 6 "38400"
    freie Ports sind 3,5&7
    benutze denn Port 5 und habe ein GNS Modul
    meine mixsernavistarter.mscr sie so aus

    # Enable all script error messages
    ErrorLevel ( "warn" )

    # -----------------------------------------
    # Adjust following variables to your system:

    NAVI_SW_WINDOW_TITLE = "Mobile Navigator"
    NAVI_SW_PROCESS_NAME = "navigon.exe"

    If ( ProcExists( NAVI_SW_PROCESS_NAME ) = TRUE )
    Show( NAVI_SW_WINDOW_TITLE )
    Exit
    EndIf

    # INSTALLDIR must contain: MixSerDrv.dll , mixser_tmc.bin, activatedevice.exe
    INSTALLDIR = "\StorageCard\MixSer"

    # MIXSER_PORT must be a free COM port number in your system
    # Set the TMC port of your navigation software to this port!
    MIXSER_PORT = 5

    # COM port name and baudrate of the TMC chip
    TMC_PORT = "COM6:"
    TMC_BAUD = 38400

    # Optional: Your favorite FM frequency. MixSerDrv will tune to this frequency when MixSerDrv is activated
    # Examples: 10520 means 105.2 Mhz; 9440 means 94.4 MHz, etc.
    TMC_START_FREQ = 10520

    # Optional: In case MixSerDrv does not work properly, try with following lines set to 1
    TMC_SKIP_INIT = 1
    TMC_NOWAIT_FOR_RESPONSE = 1

    # Optional: GNS TMC chip only: Scan for next FM station if no TMC data received for x milliseconds
    # value of 0 deactivates this function
    GNS_TMC_DATA_TIMEOUT = 10000

    # Navigation software executable
    NAVI_SW_PATH = "\StorageCard\NAVIGON\navigon.exe"

    # If DEBUG is 1 then a log file is written into INSTALLDIR every time when MixSerDrv is activated
    DEBUG = 0

    # -----------------------------------------

    # you should know what you do from here on !!

    # MixSerDrv used as a Serial Port Sniffer (deactivates all TMC functionality!)
    # GPS_PORT <==> MixSerDrv <==> MIXSER_PORT
    # GPS_PORT = "COM2:"
    # GPS_BAUD = 9600
    # GPS_SNIFF_MODE = 1

    # copy MixSerDrv driver DLL to Windows directory, if not already exists
    If ( FileExists("\Windows\MixSerDrv.dll") = FALSE )
    Copy( INSTALLDIR & "\MixSerDrv.dll", "\Windows\MixSerDrv.dll", TRUE )
    EndIf

    # write settings for MixSerDrv to registry
    RegWriteString( "HKLM", "\Drivers\MixSer", "FriendlyName", "MixSerDrv" )
    RegWriteString( "HKLM", "\Drivers\MixSer", "Dll", "MixSerDrv.dll" )
    RegWriteString( "HKLM", "\Drivers\MixSer", "Prefix", "COM" )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "Index", MIXSER_PORT )
    RegWriteString( "HKLM", "\Drivers\MixSer", "InstallPath", INSTALLDIR )
    RegWriteString( "HKLM", "\Drivers\MixSer", "TmcPortName", TMC_PORT )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "TmcBaudRate", TMC_BAUD )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "TmcStartFreq", TMC_START_FREQ )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "TmcSkipInit", TMC_SKIP_INIT )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "TmcNoWaitForResponse", TMC_NOWAIT_FOR_RESPONSE )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "GnsTmcDataTimeout", GNS_TMC_DATA_TIMEOUT )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "DebugMode", DEBUG )
    RegWriteDWord ( "HKLM", "\Drivers\MixSer", "GpsSniffMode", GPS_SNIFF_MODE )

    # activate the new COM port
    RunWait ( INSTALLDIR & "\activatedevice.exe", "\Drivers\MixSer" )

    # start the navigation software
    Run ( NAVI_SW_PATH )

    # wait for Navigon to start up until the STVO disclaimer is shown
    # you can lower the timeout if your Navigon boots up faster than 30sec
    Sleep( 30000 )

    # press the "OK" button of Navigon STVO disclaimer on a 800x480 screen
    MouseClick(NAVI_SW_WINDOW_TITLE, 610, 430 )


    meine settings in navigon so

    <TMC>
    <RadioStationScan>1</RadioStationScan>
    <AutoRecalculation>1</AutoRecalculation>
    <preferPay>1</preferPay>
    <TMCPort>5</TMCPort>
    <TMCBaudrate>38400</TMCBaudrate>
    <DRVPrefix>COM</DRVPrefix>
    <History>1</History>
    </TMC>


    hatte auch schon die TmcHal.dll auf Port5 und 6 getauscht obwohl man das beim GNS Modul ja garnicht braucht wie ich das gelesen habe.
    in Navigon wird mir bei denn TMC einstellungen immer nur 3 Punkte angezeigt keine Radio Frequenzen.

    Hoffe das mir einer helfen kann der auch ein GNS Modul verwendet und meine MSCR Datei mit seiner vergleicht

    Gruß Olaf

  2. # ADS
    Circuit advertisement
    Dabei seit
    Always
    Beiträge
    Many


     

  3. Top | #2
    Male
    Super-Mod
    Avatar von krebsi
    My Car
    VW Jetta Hybrid SEL2 in Oryx-White
    Radio
    Jetzt RNS-315. Vorher Roadrover i7037 i10, S100 usw.
    OS-Version
    Windows CE
    Dabei seit
    15.01.2010
    Ort
    München
    Beiträge
    6.303
    Bedankt
    474
    Erhielt 1.133x Danke in 938 Posts

    Standard

    Was hast Du denn für ein Gerät? Finde gar nichts zu dem V6026!?

  4. Top | #3
    Male
    Premium-Member
    Themenersteller
    Avatar von olsch
    My Car
    ford
    Radio
    V6026
    Dabei seit
    01.08.2014
    Beiträge
    30
    Bedankt
    2
    Erhielt 0x Danke in 0 Posts

    Standard

    ja ein china teil mit win6
    [Only members can see the link]
    wie gesagt die alten navigons funktionieren ja mit TMC sind halt nur zu träge
    und bei der 7.7.6 muss man ja denn MixSer benutzen, bekomme ihn nur nicht zum laufen mit mein GNS Modul
    deswegen wäre es nett wenn einer das gleiche modul verwendet und seine MSCR config mit meiner vergleicht.

  5. Top | #4
    Male
    Super-Mod
    Avatar von krebsi
    My Car
    VW Jetta Hybrid SEL2 in Oryx-White
    Radio
    Jetzt RNS-315. Vorher Roadrover i7037 i10, S100 usw.
    OS-Version
    Windows CE
    Dabei seit
    15.01.2010
    Ort
    München
    Beiträge
    6.303
    Bedankt
    474
    Erhielt 1.133x Danke in 938 Posts

    Standard

    Nimm mal das Navigon von hier. #50. Musst aber alles für "Storage Card" anpassen.

    [Only members can see the link]

  6. Top | #5
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    mein TMC Port ist 6 "38400"
    freie Ports sind 3,5&7
    benutze denn Port 5 und habe ein GNS Modul
    meine mixsernavistarter.mscr sie so aus
    Wenn Du den COM5 als MixSer Port benutzt, dann must Du im MN7.7.6 auch die "tmcHal.dll" auf COM5 umpatchen, da die standardmäßig auf COM6 fest eingestellt ist.

    Den TMC Port in der UserSettings.xml auf 5 einzustellen, genügt nicht.

    (ich hab auch lange rumexperimentiert, bis ich das kapiert hatte)
    Geändert von strados (02.03.2016 um 23:51 Uhr)
    =>> Bitte keine Supportanfragen per PN, dafür ist das Forum da !!!


  7. Top | #6
    Male
    Super-Mod
    Avatar von krebsi
    My Car
    VW Jetta Hybrid SEL2 in Oryx-White
    Radio
    Jetzt RNS-315. Vorher Roadrover i7037 i10, S100 usw.
    OS-Version
    Windows CE
    Dabei seit
    15.01.2010
    Ort
    München
    Beiträge
    6.303
    Bedankt
    474
    Erhielt 1.133x Danke in 938 Posts

    Standard

    Wenn Du den COM5 als MixSer Port benutzt, dann must Du im MN7.7.6 auch die "tmcgps.dll"
    Hm, Strados, ich denke es soll die "TmcHal.dll" sein.

  8. Top | #7
    Male
    Premium-Member
    Themenersteller
    Avatar von olsch
    My Car
    ford
    Radio
    V6026
    Dabei seit
    01.08.2014
    Beiträge
    30
    Bedankt
    2
    Erhielt 0x Danke in 0 Posts

    Standard

    ja die tmchal.dll hab ich auch auf 5 gepacht gehabt vorsichtshalber.

    @krebsi bei deiner version die ich jetzt benutze muss ich aber noch die ports ändern oder
    da dein TMC Gerät ja port 5 benutzt und der MixSer port 6 bei mir ist das ja genau umgekehrt.
    die pathes habe ich schon auf StorageCard geändert.

  9. Top | #8
    Male
    Super-Mod
    Avatar von krebsi
    My Car
    VW Jetta Hybrid SEL2 in Oryx-White
    Radio
    Jetzt RNS-315. Vorher Roadrover i7037 i10, S100 usw.
    OS-Version
    Windows CE
    Dabei seit
    15.01.2010
    Ort
    München
    Beiträge
    6.303
    Bedankt
    474
    Erhielt 1.133x Danke in 938 Posts

    Standard


    @krebsi bei deiner version die ich jetzt benutze muss ich aber noch die ports ändern oder
    da dein TMC Gerät ja port 5 benutzt und der MixSer port 6 bei mir ist das ja genau umgekehrt.
    Du hast doch in dem ersten Post geschrieben dass Port 5 frei ist? Dann soll es ja gehen.

    die pathes habe ich schon auf StorageCard geändert.
    Nicht "StorageCard" sondern "Storage Card", also mit Leerzeichen. Das musst Du noch in dem MixSer auch ändern. Zusätzlich kannst mal den MixSer auch ins Root der Speicherkarte kopieren. Bei manchen Users ging es nur so.


    PS:__________________________
    Oh sorry, hast ja recht mit "StorageCard".
    Geändert von krebsi (02.03.2016 um 20:08 Uhr)

  10. Top | #9
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    Hm, Strados, ich denke es soll die "TmcHal.dll" sein.
    Sorry, natürlich !
    (hab's gleich korrigiert)
    =>> Bitte keine Supportanfragen per PN, dafür ist das Forum da !!!


  11. Top | #10
    Male
    Premium-Member
    Themenersteller
    Avatar von olsch
    My Car
    ford
    Radio
    V6026
    Dabei seit
    01.08.2014
    Beiträge
    30
    Bedankt
    2
    Erhielt 0x Danke in 0 Posts

    Standard

    @Krebsi irgendwie ist was vertauscht.
    In deiner Version ist ja dein TMC Port=5 und dein freier Port=6 richtig oder ich lese das so aus deiner config.
    Bei mir ist das aber der TMC Port=6 und der freie Port=5 wie man das in meiner config sehen kann.

  12. Top | #11
    Male
    Super-Mod
    Avatar von krebsi
    My Car
    VW Jetta Hybrid SEL2 in Oryx-White
    Radio
    Jetzt RNS-315. Vorher Roadrover i7037 i10, S100 usw.
    OS-Version
    Windows CE
    Dabei seit
    15.01.2010
    Ort
    München
    Beiträge
    6.303
    Bedankt
    474
    Erhielt 1.133x Danke in 938 Posts

    Standard

    @Krebsi irgendwie ist was vertauscht.
    In deiner Version ist ja dein TMC Port=5 und dein freier Port=6 richtig oder ich lese das so aus deiner config.
    Bei mir ist das aber der TMC Port=6 und der freie Port=5 wie man das in meiner config sehen kann.
    Auf meinem Gerät ist eben das ComPort 5 frei und wird bei Primo, iGO8 und Navigon für den TMC Empfang genutzt. Die/der MixSer wandelt es aber bei Navigon von 5 auf 6 um.
    Hast Du auch den Ordner "MN Settings" gelöscht? Was für einen TMC Empfänger hast Du denn. Wo hast ihn her?

  13. Top | #12
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    Was für einen TMC Empfänger hast Du denn. Wo hast ihn her?
    Von mir, ist mit GNS Chip.
    Also nochmal step by step:
    - der TMC Treiber (USB->COM) im WinCE stellt sich auf COM6 ein. Das muss auch stimmen, sonst würden die anderen Navi Versionen nicht mit COM6 funktionieren.
    - der für MN7.7.6 "zwischengeschaltete" MixSer liest die TMC Daten über COM6 ein (TMC-Port), wandelt sie vom GNS-Protokoll ins OpenTMC-2 Protokoll um und gibt sie über COM5 wieder aus (MixSer-Port),
    - MN7.7.6 muss den COM5 öffnen, um an die TMC Daten zu kommen. Dazu muss die "5" in der UserSettings.xml eingestellt sein + in der tmcHal.dll gepatcht sein.
    - vorsichtshalber (wie krebsi schon sagte) auch den Ordner MN-Settings mal löschen (oder auch nur umbenennen).

    und der freie Port=5 wie man das in meiner config sehen kann.
    Was meinst Du mit "config" ?
    Ich würde direkt in der Registry unter "Active Devices" nachsehen (mit RegEdit2.exe, der hat eine Suchfunktion), ob der COM5 tatsächlich "frei" ist !
    =>> Bitte keine Supportanfragen per PN, dafür ist das Forum da !!!


  14. Top | #13
    Male
    Super-Mod
    Avatar von krebsi
    My Car
    VW Jetta Hybrid SEL2 in Oryx-White
    Radio
    Jetzt RNS-315. Vorher Roadrover i7037 i10, S100 usw.
    OS-Version
    Windows CE
    Dabei seit
    15.01.2010
    Ort
    München
    Beiträge
    6.303
    Bedankt
    474
    Erhielt 1.133x Danke in 938 Posts

    Standard

    Ich würde direkt in der Registry unter "Active Devices" nachsehen (mit RegEdit2.exe, der hat eine Suchfunktion), ob der COM5 tatsächlich "frei" ist !
    Noch einfacher wäre es mit igo8 zu testen.

  15. Top | #14
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    Noch einfacher wäre es mit igo8 zu testen.
    Es geht nicht um den vom TMC-Treiber belegten COM Port (der ist hier COM6, das ist bereits mit MN7.4.3 und MN7.7.5 verifiziert worden), sondern um die anderen, noch "freien" COM Ports, die dann vom MixSer benutz werden könnten.
    Da vermute ich, dass der COM5 doch nicht frei ist und deshalb TMC über den MixSer bisher nicht funktioniert.
    =>> Bitte keine Supportanfragen per PN, dafür ist das Forum da !!!


  16. Top | #15
    Male
    Super-Mod
    Avatar von krebsi
    My Car
    VW Jetta Hybrid SEL2 in Oryx-White
    Radio
    Jetzt RNS-315. Vorher Roadrover i7037 i10, S100 usw.
    OS-Version
    Windows CE
    Dabei seit
    15.01.2010
    Ort
    München
    Beiträge
    6.303
    Bedankt
    474
    Erhielt 1.133x Danke in 938 Posts

    Standard


    Es geht nicht um den vom TMC-Treiber belegten COM Port (der ist hier COM6, das ist bereits mit MN7.4.3 und MN7.7.5 verifiziert worden), sondern um die anderen, noch "freien" COM Ports, die dann vom MixSer benutz werden könnten.
    Da vermute ich, dass der COM5 doch nicht frei ist und deshalb TMC über den MixSer bisher nicht funktioniert.
    Ach, das meinst Du. Naja umschreiben und testen, umschreiben und testen.

+ Antworten
Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. [Hilfe] Dynavin N6 + MixSer mit Navigon
    Von marctim123 im Forum Navigon
    Antworten: 5
    Letzter Beitrag: 22.03.2019, 17:02
  2. MixSer läuft auch mit Navigon MN 7.7.5 Build 447
    Von GIN-Power im Forum Navigon
    Antworten: 54
    Letzter Beitrag: 07.12.2017, 18:04
  3. Antworten: 40
    Letzter Beitrag: 09.10.2013, 19:57
  4. ES1278DE + Navigon 7.7.6 läuft nicht
    Von Hellrazor im Forum Navigon
    Antworten: 4
    Letzter Beitrag: 13.07.2013, 12:41

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein

sponsored - supported by


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64