+ Antworten
Ergebnis 1 bis 15 von 15

Thema: USB Mod funktioniert nicht. Bitte um Hilfe :-)

  1. Top | #1
    Male
    Member
    Avatar von Mozart4000
    My Car
    HONDA Prelude
    Radio
    Erisin 862D
    Dabei seit
    25.04.2011
    Ort
    Bonn
    Beiträge
    24
    Bedankt
    2
    Erhielt 1x Danke für 1 Post

    Standard USB Mod funktioniert nicht. Bitte um Hilfe :-)

    Hallo zusammen,
    bei meinem Radio (Erisin ES862) habe ich am Wochenende den USB Mod angelötet. Die Anschlüsse auf dem Board sind auch genauso da wie beschrieben, aber trotz mehrmaliger Überprüfung meiner Lötkünste funktioniert es nicht. 5 Volt sind auch da. Wenn ich dann zum testen einen USB Stick einstecke, blinkt dieser nur kurz, und dann ist Ruhe. Wird anscheinend nicht erkannt. Ich habe es schon mit mehreren Sticks probiert.
    Es handelt sich dabei um kein Mesada 2440 Board, sondern um ein WinCe6 Board mit 128MB und Atlas iV Sirf. Bezeichnung lautet AIVCE6_NANO_Rel1.03. Anschlüsse sind aber genau wie bei den Mesada Boards.
    Gibt es da vielleicht einen Treiber, den man zuerst noch installieren muß oder einen anderen Trick, wie man es zum Laufen bekommt?

    Tips sind herzlich willkommen :-)
    Danke und Gruß,
    Mozart

  2. # ADS
    Circuit advertisement
    Dabei seit
    Always
    Ort
    Advertising world
    Beiträge
    Many


     

  3. Top | #2
    Male
    Super-Mod
    Avatar von Danila
    My Car
    Passat Variant B6
    Radio
    XPH-8242
    OS-Version
    Windows CE
    Dabei seit
    25.11.2009
    Ort
    München
    Beiträge
    1.553
    Blog-Einträge
    9
    Bedankt
    79
    Erhielt 369x Danke in 154 Posts

    Standard

    Ist der Sirf im Host USB Modus? Bei dem ist Device USB und Host USB an einem Port (OTG)

  4. Top | #3
    Male
    Member
    Themenersteller
    Avatar von Mozart4000
    My Car
    HONDA Prelude
    Radio
    Erisin 862D
    Dabei seit
    25.04.2011
    Ort
    Bonn
    Beiträge
    24
    Bedankt
    2
    Erhielt 1x Danke für 1 Post

    Standard

    Wie kann ich das feststellen? Leider kommen die meisten Meldungen trotz Wince-Patch auf chinesisch (habe leider noch keine andere Firmware für dieses Board gefunden). Die beiden Datenleitungen habe ich auch schon mal getauscht. Das bringt nur den Effekt, daß die
    LED am Stick dann dauerhaft brennt. Erkannt wird er nicht. Das Ziel der Aktion soll sein, daß ich die TMC GNS Box anschließen kann.
    Gruß
    Mozart

  5. Top | #4
    Male
    Member
    Themenersteller
    Avatar von Mozart4000
    My Car
    HONDA Prelude
    Radio
    Erisin 862D
    Dabei seit
    25.04.2011
    Ort
    Bonn
    Beiträge
    24
    Bedankt
    2
    Erhielt 1x Danke für 1 Post

    Standard

    Wie kann man bei der Sirf Atlas iv Cpu denn die USB Betriebsart umstellen? Ich habe eben noch mal in der Systemstserung nachgesehen und nichts gefunden. Gibt es dafür ein separates Programm oder eine Registry Eintragung?

  6. Top | #5
    Male
    Super-Mod
    Avatar von Danila
    My Car
    Passat Variant B6
    Radio
    XPH-8242
    OS-Version
    Windows CE
    Dabei seit
    25.11.2009
    Ort
    München
    Beiträge
    1.553
    Blog-Einträge
    9
    Bedankt
    79
    Erhielt 369x Danke in 154 Posts

    Standard

    Sicher mal die Registry und häng sie hier an. Alternativ wird es über ein Pin der CPU gesteuert.

  7. Top | #6
    Male
    Member
    Themenersteller
    Avatar von Mozart4000
    My Car
    HONDA Prelude
    Radio
    Erisin 862D
    Dabei seit
    25.04.2011
    Ort
    Bonn
    Beiträge
    24
    Bedankt
    2
    Erhielt 1x Danke für 1 Post

    Standard

    Hallo Danila,

    hier ist meine Registry. Ich habe auch mal ein paar Bilder des Boards angefügt. Vielleicht hat ja zufällig auch jemand eine englische Firmware dafür :-)

    [Only members can see the link][Only members can see the link][Only members can see the link][Only members can see the link][Only members can see the link]

  8. Top | #7
    Male
    Member
    Themenersteller
    Avatar von Mozart4000
    My Car
    HONDA Prelude
    Radio
    Erisin 862D
    Dabei seit
    25.04.2011
    Ort
    Bonn
    Beiträge
    24
    Bedankt
    2
    Erhielt 1x Danke für 1 Post

    Standard

    Hallo Danila,

    ich habe mal selbst die Registry durchgeschaut, und ich denke mal, man kann die Betriebsart hier einstellen:

    Registry-Einstellung:
    [HKEY_LOCAL_MACHINE \ Drivers \ BuiltIn \ USBOTG1]
    "Prefix" = "OTG"
    "Dll" = "usbotg1.dll"
    "Index" = DWORD: 1
    "Order "= DWORD: 4
    ; InterfaceType: PCIbus
    "InterfaceType" = DWORD: 5
    ; USBOTG System Interrupt-Nummer, kommentiert von Rushon
    "SysIntr" = DWORD: Ein
    "Priority256" = DWORD: 64
    "membase" = DWORD: 99 Millionen
    "MemLen" = DWORD: 4.000
    "HnpPriority256" = DWORD: 60
    "PortNum" = DWORD: 1
    "BusIoctl" = DWORD: 2a0048
    "LegacyHost" = DWORD: 1
    ; Data Memory-Größe in Byte
    "DMSize" = DWORD: 200
    ; OTGPortMode Werte: 0 - Hardware HNP; 1 - Host nur; 2 - Funktion nur, 3 - Software HNP;
    "OTGPortMode" = DWORD: 0

    ; TransceiverType valuse: 0 - Differential Tx, Rx Differential; 1 - Differential Tx, Rx single-ended;
    ; 2 - TX vereinzelt-ended, Rx Differential; 3 - single-ended Tx, Rx single-ended,
    "OTGTransceiverType" = DWORD: 2
    "HostTransceiverType" = DWORD: 2
    "IClass" = MULTI_SZ: "{A32942B7-920C-486b-B0E6- 92A702A99B35 }","{ E2BDC372-598F-4619-BC50-54B3F7848D35} =% b "," {6F40791D-300E- 44E4-BC38-E0E63CA8375C} =% b " [HKEY_LOCAL_MACHINE \ Drivers \ BuiltIn \ USBOTG1 \ OTGHOST] "Class "= DWORD: 06 "Unterklasse" = DWORD: 80 "VendorID" = DWORD: 105B "DeviceID" = DWORD: 9030 "ETDCount" = DWORD: 8 "Priority256" = DWORD: 64

    werde ich nachher mal probieren, Ich sage Bescheid...

    Gruß,
    Mozart

  9. Top | #8
    Male
    Super-Mod
    Avatar von Danila
    My Car
    Passat Variant B6
    Radio
    XPH-8242
    OS-Version
    Windows CE
    Dabei seit
    25.11.2009
    Ort
    München
    Beiträge
    1.553
    Blog-Einträge
    9
    Bedankt
    79
    Erhielt 369x Danke in 154 Posts

    Standard

    HKEY_LOCAL_MACHINE\Drivers\BuiltIn\USBOTG\OTGPortM ode = 0 -> Device USB
    HKEY_LOCAL_MACHINE\Drivers\BuiltIn\USBOTG\OTGPortM ode = 1 -> Host USB

    Was der Wert 3 bedeutet habe ich keine Ahnung. Kann auch sein, dass du eine gepatchte usbotg.dll brauchst, da bei manchen Geräten diese DLL den Wert in der Registry komplett ignorert.

  10. Top | #9
    Male
    Member
    Themenersteller
    Avatar von Mozart4000
    My Car
    HONDA Prelude
    Radio
    Erisin 862D
    Dabei seit
    25.04.2011
    Ort
    Bonn
    Beiträge
    24
    Bedankt
    2
    Erhielt 1x Danke für 1 Post

    Standard

    Mit der Registry Änderung klappt's nicht :-(

  11. Top | #10
    Male
    Super-Mod
    Avatar von Danila
    My Car
    Passat Variant B6
    Radio
    XPH-8242
    OS-Version
    Windows CE
    Dabei seit
    25.11.2009
    Ort
    München
    Beiträge
    1.553
    Blog-Einträge
    9
    Bedankt
    79
    Erhielt 369x Danke in 154 Posts

    Standard

    was passiert wenn du D+, D- und GND entsprechend an den USB Port deines PC anschließt?

  12. Top | #11
    Male
    Member
    Themenersteller
    Avatar von Mozart4000
    My Car
    HONDA Prelude
    Radio
    Erisin 862D
    Dabei seit
    25.04.2011
    Ort
    Bonn
    Beiträge
    24
    Bedankt
    2
    Erhielt 1x Danke für 1 Post

    Standard

    kann ich erst am Wochenende testen, da ich gerade beruflich im Ausland bin.

  13. Top | #12
    Male
    Member
    Themenersteller
    Avatar von Mozart4000
    My Car
    HONDA Prelude
    Radio
    Erisin 862D
    Dabei seit
    25.04.2011
    Ort
    Bonn
    Beiträge
    24
    Bedankt
    2
    Erhielt 1x Danke für 1 Post

    Standard

    Also, wie schon gesagt: Die Änderung des Registry Eintrags ändert nichts. Ich habe einen "normalen" Laptop, der OTG USB hat.
    Da kann man im Treiber des OTG Gerätes die Betriebsart wählen zwischen Host und Device. Gibt es aber anscheinend bei
    WinCE nicht :-(
    Wenn ich das GPS Board ohne +5V an einen Rechner hänge kommt "Unbekanntes Gerät", da ich ja keine Xp Treiber für das Board habe.

  14. Top | #13
    Male
    Super-Mod
    Avatar von Danila
    My Car
    Passat Variant B6
    Radio
    XPH-8242
    OS-Version
    Windows CE
    Dabei seit
    25.11.2009
    Ort
    München
    Beiträge
    1.553
    Blog-Einträge
    9
    Bedankt
    79
    Erhielt 369x Danke in 154 Posts

    Standard

    Zitat Zitat von Mozart4000 [Only members can see the link]
    Wenn ich das GPS Board ohne +5V an einen Rechner hänge kommt "Unbekanntes Gerät", da ich ja keine Xp Treiber für das Board habe.
    Es sollte als ein "mobiles Gerät" erkannt werden. Treiber gibt es zusammen mit ActiveSync. Sind D+/D- evtl. vertauscht?

  15. Top | #14
    Male
    Member
    Themenersteller
    Avatar von Mozart4000
    My Car
    HONDA Prelude
    Radio
    Erisin 862D
    Dabei seit
    25.04.2011
    Ort
    Bonn
    Beiträge
    24
    Bedankt
    2
    Erhielt 1x Danke für 1 Post

    Standard

    Habe ich auch schon probiert. Dann wird es gar nicht erkannt. Komischerweise ist auf der D+ Leitung auch eine Spannung von 3,2V.
    Laut den USB Spezifikationen wird die aber normalerweise nur zur Erkennung des USB2.0 Formats verwendet bei Devices.
    Auf der D- Leitung ist nichts drauf; auch keine negativen 3,2Volt. Es ist schade, daß man bei den CE Treibern nicht die Betriebsart
    umstellen kann. Bei den XP und W7 Treibern geht das nämlich. ich denke mal, das ist das Problem. Und ich weiss auch noch nicht,
    wie ich das lösen kann.

  16. Top | #15
    Male
    Member
    Themenersteller
    Avatar von Mozart4000
    My Car
    HONDA Prelude
    Radio
    Erisin 862D
    Dabei seit
    25.04.2011
    Ort
    Bonn
    Beiträge
    24
    Bedankt
    2
    Erhielt 1x Danke für 1 Post

    Standard


    Hallo Danila,

    da ich mit dem GPS Board nicht weitergekommen bin, habe ich mir jetzt mal ein anderes besorgt.
    Ich habe gestern mal meine Lötkünste beansprucht und habe nun ein NOWADA 2450 Board drin. Damit funktioniert auch
    der USB Mod :-)
    Leider hat das Board auch nur ein chinesisches Betriebssystem WinCE6. Gibt es da bei euch eine englische Version für?
    Ich habe die ResInfo mal angehängt. Es handelt sich um ein N117 V6 Board.
    [Only members can see the link] [Only members can see the link]

    Danke und viele Grüsse!
    Geändert von Mozart4000 (13.07.2011 um 20:24 Uhr)

+ Antworten

Ähnliche Themen

  1. AS-8603 Bitte um Hilfe
    Von Ronny1970 im Forum Audiosources
    Antworten: 7
    Letzter Beitrag: 03.07.2011, 08:47
  2. Antworten: 11
    Letzter Beitrag: 06.06.2011, 12:41
  3. [GELÖST] Bitte um eure Hilfe
    Von go2run im Forum HARDWARE-Helpdesk
    Antworten: 13
    Letzter Beitrag: 17.04.2011, 16:51
  4. China-RNS Bitte um hilfe Radio reagiert nicht steht nur cam in display
    Von dome im Forum HARDWARE-Helpdesk
    Antworten: 28
    Letzter Beitrag: 26.02.2011, 13:25
  5. Antworten: 5
    Letzter Beitrag: 30.12.2010, 13:32

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein

sponsored - supported by


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64