+ Antworten
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 23

Thema: RoadRover I7037VT locks when connecting/disconnecting iPod

  1. Top | #1
    Male
    Premium-Member
    Avatar von PeterH
    My Car
    Volkswagen Touran 2007
    Radio
    RoadRover I7037VT
    Dabei seit
    29.12.2014
    Ort
    Gouda
    Beiträge
    41
    Bedankt
    8
    Erhielt 1x Danke für 1 Post

    Standard RoadRover I7037VT locks when connecting/disconnecting iPod

    Hello everybody,
    Since I have had to reinstall my Roadrover [Only members can see the link]) , using the iPod is giving serious problems. The iPod is connected to the RoadRover through USB. When you connect or disconnect the iPod when the RoadRover is switched on (doesn't matter what function, radio/navigation/etc.) the RoadRover cannot be controlled anymore. It stays fixed to what it was doing before the iPod was connected/disconnected. You cannot change function, or even volume/track/radiostation/etc. The system doesn't respond to any of the buttons. You can't even turn the system off anymore, except by stopping the car and switching it off completely.

    When the iPod is connected before the car power and the RoadRover are switched on, it usually works fine, although it has locked the system once while driving, a couple of days ago.

    I now have the following software versions installed:
    Shell: 3.06.2
    OS: AS-A6-G-BC8-VIN-U1-256-v1.42
    MCU: F37VTSI7-TH47-2V1.07

    As I said, I have had to reinstall the OS and Shell. I used to have the versions below and then the iPod worked fine, connected exactly the same as now:
    Shell: 3.03.9
    OS: AS-A6-G-BC8-1G-VIN-U1-256-v1.36
    MCU: F37VTSI7-TH47-2V1.07
    Connecting and disconnecting the iPod while the Roadrover was on was no problem at all.
    Unfortunately, I don't have these software versions anymore to try if they solve the problem. I would also rather keep the newer versions, since I think they perform slightly better.

    I haven't flashed the MCU, so that is still the same as before. I have not changed any of the hardware, so that should not affect the behaviour. I do use a TMC-receiver connected to USB, but that didn't interfere with the iPod before reinstalling the OS/shell.

    I have flashed the OS (with the same version 1.42, downloaded from China-RNS) and reinstalled the shell (3.06.2, also downloaded from China-RNS) several times, but this did not improve the iPod-function.

    Does anyone have any ideas about what I could do to get the iPod working normally again?

  2. # ADS
    Circuit advertisement
    Dabei seit
    Always
    Ort
    Advertising world
    Beiträge
    Many


     

  3. Top | #2
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    The iPod is connected to the RoadRover through USB.
    There is a special cable to connect iPod, iPhone, iPad. Did you use this ? (I wonder about "USB" !?)
    =>> Bitte keine Supportanfragen per PN, dafür ist das Forum da !!!


  4. Folgende Benutzer bedankten sich bei strados:


  5. Top | #3
    Male
    Premium-Member
    Themenersteller
    Avatar von PeterH
    My Car
    Volkswagen Touran 2007
    Radio
    RoadRover I7037VT
    Dabei seit
    29.12.2014
    Ort
    Gouda
    Beiträge
    41
    Bedankt
    8
    Erhielt 1x Danke für 1 Post

    Standard

    Hi Strados,
    I didn't get an iPod cable with the RoadRover, so I assumed it should be connected through the USB cable with a standard iPod-USB cable that I had lying around.
    It worked perfectly before with LinkPod.

    Sent using Forum Fiend v1.3.3.

  6. Top | #4
    Male
    Premium-Member
    Themenersteller
    Avatar von PeterH
    My Car
    Volkswagen Touran 2007
    Radio
    RoadRover I7037VT
    Dabei seit
    29.12.2014
    Ort
    Gouda
    Beiträge
    41
    Bedankt
    8
    Erhielt 1x Danke für 1 Post

    Standard

    I decided to flash the OS again. I installed the GUI but there was no improvement.

    So I flashed the OS again and installed the 3.06.2 GUI again. Strangely enough, now the iPod could be connected and disconnected without any problems, but with a clearly audible windows-sound (correct "boing" for connecting devices).

    Maybe flashing the OS a couple of times cleared something up, I don't know. But let me test this for a week or so and find out whether the problem with the iPod has disappeared.

  7. Top | #5
    Male
    Premium-Member
    Themenersteller
    Avatar von PeterH
    My Car
    Volkswagen Touran 2007
    Radio
    RoadRover I7037VT
    Dabei seit
    29.12.2014
    Ort
    Gouda
    Beiträge
    41
    Bedankt
    8
    Erhielt 1x Danke für 1 Post

    Standard

    The iPod seems to work fine now with the RoadRover. I find it worrying that I have had to flash the OS and reinstall the GUI several times before they finally work well.
    Also, the dealer hasn't responded at all to my request for the iPod-cable that should have been supplied with my RoadRover, but wasn't. I'm very glad that at least the China-RNS-forum is there to provide help when I need it. Thanks a lot, guys!
    (I will try to close this thread.)

  8. Top | #6
    gerco
    Gast Avatar von gerco

    Standard

    I find it worrying that I have had to flash the OS
    Installing a new OS must run smoothly.
    When the bar shows "finished" the unit must turn off immediately (black screen).
    Rebooting MUST be done within 1min.
    If this time is longer you must reinstall again.

    One time it was necessary to disconnect the power supply
    If your is auto reboot takes more than 2 min or longer the update failed.
    You will not see this as the version No shows the new one. But one or more function will not work or are missing. This missing function are different - not fixed.
    Do not ask me why. I had this trouble a couple of times. Even with different SD cards.

  9. Top | #7
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    I find it worrying that I have had to flash the OS and reinstall the GUI several times before they finally work well.
    Maybe you fetched a OS version which need to format the flash memory before updating.
    Some OS versions MUST be installed after formatting all internal flash memory. That's neccessary cause the registry of the WinCE is splitted in a system and user part ! For example OS V1.55 included many Microsoft patches and would'nt run with a mix of new system registry + old user registry.

    But now you are lucky to have a running unit incl. iPod
    =>> Bitte keine Supportanfragen per PN, dafür ist das Forum da !!!


  10. Top | #8
    Male
    Premium-Member
    Themenersteller
    Avatar von PeterH
    My Car
    Volkswagen Touran 2007
    Radio
    RoadRover I7037VT
    Dabei seit
    29.12.2014
    Ort
    Gouda
    Beiträge
    41
    Bedankt
    8
    Erhielt 1x Danke für 1 Post

    Standard

    Thanks Gerco and Strados! Good to know those things. I think the updates went well and reboots were within one minute but I'm not sure, because I didn't know that was important.
    Maybe flashing the OS twice is a good idea, considering that flash memory might have to be cleared.

    Useful lessons for the next time!

    Sent using Forum Fiend v1.3.3.

  11. Top | #9
    Male
    Premium-Member
    Themenersteller
    Avatar von PeterH
    My Car
    Volkswagen Touran 2007
    Radio
    RoadRover I7037VT
    Dabei seit
    29.12.2014
    Ort
    Gouda
    Beiträge
    41
    Bedankt
    8
    Erhielt 1x Danke für 1 Post

    Standard RoadRover I7037VT locks when connecting/disc

    To make te solution complete: the dealer had promised to send me an iPod-cable.



    Sent using Forum Fiend v1.3.3.

  12. Top | #10
    Male
    Premium-Member
    Themenersteller
    Avatar von PeterH
    My Car
    Volkswagen Touran 2007
    Radio
    RoadRover I7037VT
    Dabei seit
    29.12.2014
    Ort
    Gouda
    Beiträge
    41
    Bedankt
    8
    Erhielt 1x Danke für 1 Post

    Standard

    Sorry, not solved at all. Today we had a freeze while the navigation (igo 8) was on and the iPod was just connected, not playing music.

    Sent using Forum Fiend v1.3.3.

  13. Top | #11
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    we had a freeze while the navigation (igo 8) was on and the iPod was just connected, not playing music.
    With new iPod cable or still only with USB connected ?
    =>> Bitte keine Supportanfragen per PN, dafür ist das Forum da !!!


  14. Top | #12
    Male
    Premium-Member
    Themenersteller
    Avatar von PeterH
    My Car
    Volkswagen Touran 2007
    Radio
    RoadRover I7037VT
    Dabei seit
    29.12.2014
    Ort
    Gouda
    Beiträge
    41
    Bedankt
    8
    Erhielt 1x Danke für 1 Post

    Standard

    Still only through USB. I haven't received the iPod cable yet. I expect to receive the iPod-cable in about 2 weeks time.
    This (through USB) used to work perfectly, with the previous software versions that I mentioned in the first post.
    This is new to me: could it be something in the MCU that is not working correctly?
    Geändert von PeterH (10.05.2015 um 22:54 Uhr)

  15. Top | #13
    jetzt 7. China-Navi Avatar von strados
    My Car
    Toyota RAV4.3, Alfa Romeo Spider V6 3.0
    Radio
    Roadrover I7104TR + I7037V2, Sony, Navigon
    OS-Version
    Windows CE
    Dabei seit
    17.09.2010
    Ort
    D
    Beiträge
    11.318
    Blog-Einträge
    1
    Bedankt
    300
    Erhielt 2.452x Danke in 1.973 Posts

    Standard

    could it be something in the MCU that is not working correctly?
    USB interface does'nt touch the MCU. These connections go direct into the WinCE Mainboard.
    =>> Bitte keine Supportanfragen per PN, dafür ist das Forum da !!!


  16. Top | #14
    Male
    Premium-Member
    Themenersteller
    Avatar von PeterH
    My Car
    Volkswagen Touran 2007
    Radio
    RoadRover I7037VT
    Dabei seit
    29.12.2014
    Ort
    Gouda
    Beiträge
    41
    Bedankt
    8
    Erhielt 1x Danke für 1 Post

    Standard

    I think I'll try a different SD card for the navigation software. I'll post the results here, but again, this will take some days of testing because I haven't been able to define the exact circumstances in which the problem occurs.

    Sent using Forum Fiend v1.3.3.

  17. Top | #15
    Male
    Premium-Member
    Themenersteller
    Avatar von PeterH
    My Car
    Volkswagen Touran 2007
    Radio
    RoadRover I7037VT
    Dabei seit
    29.12.2014
    Ort
    Gouda
    Beiträge
    41
    Bedankt
    8
    Erhielt 1x Danke für 1 Post

    Standard


    A different SD-card (Kingston 8GB) made no difference. The problems still occur. It seemed to be quicker/more frequent when the iPod battery was low (so it needed charging through the USB cable) than when the iPod battery was full.
    Still, even with a full iPod battery the problems occurred after using the iPod and navigation for an hour.
    I will wait for the iPod-cable to arrive and test with that.

+ Antworten
Seite 1 von 2 12 LetzteLetzte

Ähnliche Themen

  1. iPod problems with Motor One (M1) / RoadRover D2280
    Von alexspires im Forum We speak english
    Antworten: 7
    Letzter Beitrag: 27.10.2016, 19:02
  2. [GELÖST] Roadrover I7037VT stuck on boot logo after inject_v9
    Von PeterH im Forum We speak english
    Antworten: 46
    Letzter Beitrag: 23.03.2015, 18:38
  3. Connecting Andrioid phone to roadrover
    Von mhenawy im Forum We speak english
    Antworten: 4
    Letzter Beitrag: 28.02.2013, 10:24
  4. iPod-Kabel für Roadrover D2280
    Von ali im Forum Gefunden !
    Antworten: 10
    Letzter Beitrag: 05.11.2012, 14:53
  5. Musikstreaming-Client für iOS und RoadRover iPod-Applikation
    Von Jeanlucpica im Forum Application Software Suite
    Antworten: 0
    Letzter Beitrag: 24.05.2012, 11:35

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein

sponsored - supported by


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64